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Lesson:  Connecting Surveys, Maps, and Apps:  Creating and Analyzing field data in a Survey, Map, 
Dashboard, and Story Map          Joseph J. Kerski PhD GISP jkerski@esri.com   Updated:  May 2024 

Connecting components of modern GIS, including field surveys, dashboards, interactive maps, spatial 
analysis, and multimedia web mapping applications such as dashboards and story maps help 
organizations understand key local issues and situations and take action.   

Lessons:  This set of 8 lessons (posted here as a 21.5 MB zip file containing lesson and all images and 
graphics needed) (and the PDF without the image files is attached to the same above post) guides you 
through the entire process from the creation of a field survey in ArcGIS Survey123, mapping the 
resulting data in ArcGIS Online, analyzing the data, creating and using an ArcGIS Dashboard, to the 
process of creating an ArcGIS StoryMap.  It does so through 8 lesson components:  4 introductory 
lessons, followed by 4 "deeper dive" lessons that are on an intermediate skill level.  Step-by-step 
instructions are included, but even more importantly, deeper thinking is encouraged about the insights 
gained through these tools. 

Themes:  Three key themes run through these lessons and provide the major teaching and learning 
objectives:  (1)  Modern web GIS is a platform.  When the components are linked together, these 
provide for powerful tools for data gathering, mapping, analysis, and communication.  (2)  Modern GIS 
platform components are approachable, able to be learned in a short amount of time, and 
configurable.  In this case, the components used are:  ArcGIS Story Maps, ArcGIS Online maps including 
visualization and analysis capabilities, ArcGIS Dashboards, and ArcGIS Story Maps.  (3)  Once key skills 
are learned, they can be built on for extended learning (hence the 4 'deeper dives' lessons included 
here).   

Users:  These sets of lessons can be used by the GIS professional community in nonprofit organizations, 
government agencies, and private industry, and also by instructors at the upper secondary but especially 
in community, tribal, and technical college and university courses to foster spatial thinking, critical 
thinking, and rigorous development of GIS skills, using up-to-date GIS tools and spatial data.  In 
education, these lessons could be used in GIS courses and programs, but also in environmental or earth 
science, hydrology, cultural or physical geography, architecture, history, sociology, economics, or any 
course in which the "where" question matters and in which fieldwork is important.  

Example and Extensions:  This lesson focuses on walkability, and walkable neighborhoods:  How 
walkable is a neighborhood?  Collect walkability information in a neighborhood:  Is it walkable?  How 
walkable (rating) is it?  What characteristics of the site impact its walkability?  Where is the site located, 
and do you have a photograph of it?  How does walkability vary in my community and how does it 
compare to other communities?  How can I visualize and spatially analyze the patterns of walkability 
with maps and dashboards?  How can I communicate the economic, social, health, and aesthetic reasons 
why communities care about walkability,  the results of my walkability survey, and a call to action in a 
StoryMap?  

Despite the focus on walkability here, the same concepts in these lessons can be used for any theme or 
subject, from local to global—pedestrian and vehicle counts, water quality, weather observations, 
housing or business type, zoning, light poles, recycling bins, invasive species, litter, and other features or 
issues in the natural or built landscape.  After these lessons are used, the learner can dig even deeper 

mailto:jkerski@esri.com
https://community.esri.com/t5/education-blog/new-workshop-and-lesson-on-connecting-surveys-maps/ba-p/1419582
https://community.esri.com/t5/education-blog/new-workshop-and-lesson-on-connecting-surveys-maps/ba-p/1419582
https://community.esri.com/t5/education-blog/new-workshop-and-lesson-on-connecting-surveys-maps/ba-p/1419582
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with the links I provide in the lesson, and with more powerful expressions using Arcade, the ArcGIS 
Experience Builder, and with the ArcGIS Developer Tools, SDKs, and APIs. 

Evaluation:  I have successfully tested this set of lessons in a wide variety of settings from the GIS 
professional community to students in university GIS courses over a series of years, and in multiple 
countries of the world. 

Prerequisites and Scaffolding:  The introductory lessons require no prior experience beyond the basics 
of understanding what a web map is, what a GIS layer is, how attributes and geography work together, 
and about the basic navigation of ArcGIS Online maps and user content.  The intermediate lessons build 
on the introductory lessons or equivalent experience, and immerse the learner into such tasks as map 
actions, building Arcade expressions, doing spatial analysis including clustering and hot spots analysis, 
using generative AI to build field surveys, and creating Map Tour and Express Map components in 
StoryMaps. 

Functions included:   Survey123:  Likert scale, single and multiple choice questions, maps, images, 
generative AI surveys.  ArcGIS Online Map Viewer:  symbolization (styling), classification, basemaps, 
transparency, create charts, clustering, hot spot, filtering, custom symbols, popups, and other analysis 
tools.  Dashboards:   Indicators, maps, bar graphs, pie charts, Arcade expressions, legends, 
images.  StoryMaps:   Map tours, popups, text, images, separators, themes, settings, videos, and 
more.       

Requirements:     
Time:   I have run the first 4 lessons of this workshop in demonstration mode in as little as one hour.  If 
you read these first 4 lessons (pages 1-20 of the 43 pages of content available) in an hour, you will gain 
some key skills.  But as is the case with so much in the world of GIS, working through the activities 
yourself is the best way to learn.  Plan on 2 to 4 hours to work through the first 4 lessons, and 4 hours to 
work through Lessons 5-8.   Add more time if you are not familiar with using GIS or Web GIS, and 
subtract time if you are a regular ArcGIS Online user.  
 
Hardware:   You can run these lessons on a large tablet or a laptop computer.  A small laptop or phone 
will not give you enough 'real estate' screen space to operate all the buttons in the various tools.    
 
Software:   (1) An ArcGIS Online account in which you have the User Type of Creator and the Role of 
Publisher.  (2)  The 21.5 MB zip file associated with this lesson, located here, which contains all 
necessary components:  Selected field photographs, custom point graphics, and this lesson in PDF and in 
DOCX formats (DOCX is included so that you will be able to easily modify the lesson if you wish).  No 
software is required beyond a web browser as you will be running ArcGIS Online which is a SaaS 
Software as a Service, in the cloud.  An internet connection is critical. 

Organization:  This lesson set is organized in 8 parts:   
 
Introduction: 
Part 1:  Creating a field survey using ArcGIS Survey123.    Page 3 
Part 2:  Creating and analyzing a map from your survey data.  Page 6 
Part 3:  Creating an ArcGIS Dashboard from your survey data.  Page 11 
Part 4:  Creating an ArcGIS StoryMap from your field data.  Page 14 

https://developers.arcgis.com/arcade/
https://www.esri.com/en-us/arcgis/products/arcgis-experience-builder/overview
https://www.esri.com/en-us/arcgis/products/arcgis-experience-builder/overview
https://developers.arcgis.com/
https://esriis-my.sharepoint.com/:u:/g/personal/jose5139_esri_com/ET92gcwht3tHhPdHpLb4ndABUU2NHi7QOcuMS_LOWqmxew?e=Eh3VMn
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Deeper Dive: 
Part 5:  Creating a field survey using the Survey123 AI Assistant plus Branching.  Page 21 
Part 6:  Perform spatial analysis on your mapped data.   Page 25 
Part 7:  Adding intermediate elements to your ArcGIS Dashboard.  Page 31 
Part 8:  Adding intermediate elements to your ArcGIS StoryMap.   Page 42 
 

Part 1:  Creating a field survey using Survey123.    
A survey will allow you and others to collect data about an issue, theme, or situation, on a mobile device 
in the field or via a web browser on a laptop or tablet. 
 
[1a].  Go to https://survey123.arcgis.com > Sign in with your ArcGIS Online account (again, in which you 
have the User Type of Creator and the Role as Publisher).  Or go to www.arcgis.com > Sign in > Use app 
launcher > select ArcGIS Survey123.  
 
[1b].  Create a new survey > Use the web designer > Get Started > allow a few moments for the feature 
service to get created. 

 
[1c].  Provide some metadata (name, tags, summary, thumbnail image):   Walkability Survey | 
Walkability, pedestrians, smart cities | A survey to assess if and how different areas in a community are 
walkable.   >  Create.  
 
[1d].  Design the survey.    
 

(1) Set the survey title:  Walkability Survey. 
(2) Add > question #1:  Single Select:   1. Pedestrian Friendly or Unfriendly?   Create 2 choices:  

Pedestrian Friendly, and Pedestrian Unfriendly.  Do not allow “other.”  Make this a required 
question.  > Save. 

(3) Add > question #2:  Likert scale.  Label:  2.  Rate the walkability of this site.  For “items” indicate:  
Horrible for pedestrians, Not ideal for pedestrians, Neutral, Good for pedestrians, Excellent for 
Pedestrians.  > Save.  

(4) Add question #3:  Multiple Select:  Label:  3.  Tick all characteristics that describe the site:   
Dedicated path or sidewalk, Wide path or sidewalk, Poor surface condition, Dangerous cross 
traffic, No path or sidewalk, Obstructions:  Branches, snow, etc., Unsafe.  7 characteristics total.  
Do not allow “Other”.  > Save.   

(5) Add question #4:   Map.  Point.   Label:  4.  Where is the site located?   Set Default Map to 
“OpenStreetMap”.   Tick “Use device’s location and ask for location when asking this question.”  

https://survey123.arcgis.com/
http://www.arcgis.com/
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For the map’s location, search for your community (or where this workshop is being held) and 
set the scale and location where you anticipating you collecting the most data.  > Save.   

(6) Add question #5:  Image.  Label:  5.  Submit a photograph of the site. > Browse Images or use 
camera  >  Save.  Your survey should look similar to this, below: 

 

 

 



 

Connecting Surveys, Maps, and Apps   -:-       Author:  Joseph J. Kerski, PhD GISP, Esri -:-    Page 5 of 44 
 

 
 

(7) Options:   Change text to: Thank you.  Your walkability response was submitted successfully. 
 
[1e].  Preview the survey.  Preview what the survey will look like on tablet and phone.   Review.  Add a 
test point.  Close preview.  If necessary, make adjustments to your survey.   
 
[1f].  Publish.  Allow a few minutes for feature survey to be published.  
 
[1g].  > Collaborate tab > Share the Survey > Tick:  Open survey in browser directly.  Then, under “who 
can submit to this survey?” > Everyone.  Then, under “What can submitters do?”, tick “Add and update 
records”.  Before leaving this screen, copy the “arcg.is” link near the top of the Collaborate page under 
“Link.”  Example survey that the author created:  https://arcg.is/11W5551  At bottom of screen > Save.   
Create a QR code for your survey and save that as well.  For the author’s survey, it is here: 

https://arcg.is/11W5551
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[1h].  Go back to design > options > after “… was submitted successfully” text, add:  Click here to submit 
another survey.  Make “here” a LINK and link it to the URL from the previous step (the arcg.is link). 
 
[1i].  Resave and republish.  
 
[1j].  Add 1-2 test points into your survey.  Make sure your survey is working.  Feel free to use the 3 
images included in this lesson.  Their locations are indicated by the file names, below:   Photo A is 
located at latitude 39.625380, longitude -105.320675, and so on: 
 

 
 
Part 2:  Creating and analyzing a map from your survey data. 
A map will allow you and others to visualize your survey data, showing patterns and relationships, and 
allow you to perform spatial analysis.  
 
[2a].  Examine your data thus far.   
 
Your survey has been created containing an editable feature service in ArcGIS Online.   
 
When done adding your test points, click on the Data tab at the top of the survey and verify that your 
point(s) was added to the map.  If you added the sample points, they will appear as follows: 
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Click on the Analyze tab to see more information about your points entered thus far.  If you entered the 
sample points, the analysis zone will look similar to this, below: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 

[2b].  Open a new browser tab > Go to www.arcgis.com > Sign in > Go to Content > My Content.  In list 
of folders on left, find the folder (beginning with “Survey” in the title) with your new survey, as follows: 
 

http://www.arcgis.com/
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This folder will contain a form, a feature layer (hosted), and 1-2 other feature layers (form, hosted, view, 
and results, hosted, view).   Click on feature layer (hosted) > open the item contents page > examine the 
metadata.  Fill in the summary and description as “Walkability survey feature layer.”   
 
[2c].   Open the item details page of your feature layer and make sure that these 2 check boxes are 
ticked:   Prevent from being accidentally deleted, and approve this layer to be shared with the public 
when editing is enabled, as shown below.  

 
 
[2d].  Make sure the form and the feature layer (hosted) are both shared with Everyone. 
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[2e].  Open your feature layer in a web map:   Open the feature layer (hosted) so that you are examining 
its item contents page.  In the upper right of this feature layer content item page > Open in Map Viewer.  
Pan and zoom the map to your study area.  Verify that your added point(s) exists.  If desired, change 
basemap to another of your choice.  Change styles > choose attributes >  1.  + Field > Pedestrian friendly 
or unfriendly >  Under Pick A Style > Style Options > Pedestrian Friendly > Uploaded Symbols > Navigate 
to folder where you downloaded the content for this workshop > choose the green pedestrian friendly 
symbol.  Repeat for hollow pedestrian “UN” friendly symbol.   Adjust symbol sizes as necessary.  Your 
points will appear similar to the following: 
 
 

 
 
[2f].  Save your map (save as) and provide some metadata for the map:  Walkability Map from Workshop 
Survey or something similar.   
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[2g].  Share your map with everyone:   If you receive a sharing error, re-check step 2c above.  

 
 
[2h].  Test your map:  Copy the resulting URL of your map.  Test its ability for sharing with anyone by 
opening it in an incognito browser window. 
 
If it includes an organization name in the URL, such as: 
https://denverro.maps.arcgis.com/apps/mapviewer/index.html?webmap=6cdc3d07021945b4baa5944f
dd4b6966  
 
Remove the organization name and replace it along with the word “maps” with www so that it reads as 
follows, and open this generic URL in a browser window, making sure your map appears with your 
added walkability survey points: 
https://www.arcgis.com/apps/mapviewer/index.html?webmap=6cdc3d07021945b4baa5944fdd4b6966  
 
[2i].  With your URL for your map copied, go back to the tab containing your survey design form. > 
Design > Settings > Options > Thank You Screen > Edit the text under the check box, so that it reads:  
Excellent!  Your walkability data was submitted successfully.  Click here to submit another survey.  Click 
here to see your point on this interactive web map!  Now get walking!   For the text “here”, click on the 
Link symbol and for the link paste the URL of your map (the generic URL you copied above) >  Save > 
Preview > (although you won’t be able to see the end screen you just edited on the preview) > Publish.  

https://denverro.maps.arcgis.com/apps/mapviewer/index.html?webmap=6cdc3d07021945b4baa5944fdd4b6966
https://denverro.maps.arcgis.com/apps/mapviewer/index.html?webmap=6cdc3d07021945b4baa5944fdd4b6966
https://www.arcgis.com/apps/mapviewer/index.html?webmap=6cdc3d07021945b4baa5944fdd4b6966
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If you wish, add another point to your survey and make certain the ‘end screen’ has been successfully 
changed and that the link lands on your web map. 
 
[2j].  Data Management:  Go to your ArcGIS Online content.  Move the map you just created into the 
folder containing the survey form and the feature layers, so that everything for this walkability project is 
contained in that single folder. 
 
Congratulations!  You have now created: 

1)  A field survey. 
2) A web map. 

 
Now you are ready to create a dashboard ! 
 
Part 3:  Creating a dashboard from your survey data. 
A dashboard allows you and others to quickly visualize your survey results in a series of maps and 
graphs.   
 
[3a].  While viewing your web map, in the left toolbar > Share > Create a web app > Dashboard. 
 

 
 
[3b] Enter a title such as “Walkability Workshop Dashboard” and other metadata (tags, summary).  
Check to ensure that you are saving the dashboard in the folder containing your other items for this 
project > Create dashboard. 
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Tick “share this app in the same way as the map.”  > Done.  
 
[3b].  Edit your dashboard.  > + sign (add element)  > go to top > Add Header:  Take default title:  
Walkability for Workshops Dashboard. 
 
[3c].  Edit your dashboard with additional items: 
 
Use + sign > Add element > go to right side > Pie chart > Select Walkability survey feature layer > 
Grouped Values  > Category Field:  Pedestrian Friendly or Unfriendly?   Take default colors or adjust if 
you wish.   General:  Title:  Is the location pedestrian friendly or unfriendly?  > Done.   
 
Use + sign > Pie chart > select walkability survey feature layer > Grouped Values > Category Field:  Rate 
the Walkability of this site: > Take default colors or adjust if you wish.  General:  Title:  Rate the 
walkability of this site > Done. 
 
Use + sign > Add indicator > Select walkability survey feature layer > Statistic:  Count.  General > Add 
title:  The Number of points added to the survey thus far is:  > change background color to an off white > 
Done. 
 
Use + sign > Add map legend.   Change the background color to light green. 
 
Use + sign > Add rich text:   Walkability enhances a community’s livability, economic viability, and safety.  
This dashboard displays the results of a crowdsourced field survey that asks participants to indicate 
whether a location is walkable or not, to rate it, and to describe its attributes.  Then:  Change alignment 
to center.  Change the background color to a light yellow. 
 
Use + sign > Add list > select walkability survey feature layer > List:  Advanced formatting:  Enable:  Scroll 
down to past Line item template box:  Click on { } brackets > Click “tick all characteristics that describe 
the site” as shown below.  
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Then > General:  Title:  Characteristics indicated:  > Done. 
 
Use + sign > add embedded content > image.  Use the author’s image if you wish, on:  
https://live.staticflickr.com/7805/33263417808_640912b3bf_w.jpg.   If Flickr does not connect use the 
same image via Twitter/X:  
https://pbs.twimg.com/media/GMV8in2XwAADbIc?format=png&name=small   If X does not work use 
this link from LinkedIn:  https://media.licdn.com/dms/image/D4D22AQGtK-zY3ecrMQ/feedshare-
shrink_800/0/1714405093945?e=1717027200&v=beta&t=nhAVsA4bXcpSK4VgHM_V66gliIDLHUbUrj3ts
Ym52PA  Make final adjustments to the size, placement, and add titles to the elements in your 
dashboard, if you wish.  
 
Position your elements where you wish them to be on the map.  Use move tool to move the elements 
and the configure tool to edit the elements: 

https://live.staticflickr.com/7805/33263417808_640912b3bf_w.jpg
https://pbs.twimg.com/media/GMV8in2XwAADbIc?format=png&name=small
https://media.licdn.com/dms/image/D4D22AQGtK-zY3ecrMQ/feedshare-shrink_800/0/1714405093945?e=1717027200&v=beta&t=nhAVsA4bXcpSK4VgHM_V66gliIDLHUbUrj3tsYm52PA
https://media.licdn.com/dms/image/D4D22AQGtK-zY3ecrMQ/feedshare-shrink_800/0/1714405093945?e=1717027200&v=beta&t=nhAVsA4bXcpSK4VgHM_V66gliIDLHUbUrj3tsYm52PA
https://media.licdn.com/dms/image/D4D22AQGtK-zY3ecrMQ/feedshare-shrink_800/0/1714405093945?e=1717027200&v=beta&t=nhAVsA4bXcpSK4VgHM_V66gliIDLHUbUrj3tsYm52PA
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An example of what your dashboard could look like is below: 
 

 
 
[3d].  Go into the configuration for each of your pie charts > General > Name - and give them more 
descriptive names. 
 
[3e].   Save and share your dashboard. 
 
Part 4:  Creating a storymap from your field data. 
A storymap is a web mapping application that allows you, using multimedia (audio, video, photographs, 
text, and other elements) and interactive web maps, to tell the story about the problem you are 
studying, along with offering possible solutions with a call to action.   
 
[4a].  Go to your Content in ArcGIS Online:   You should have at least the following layers.  Access your 
web map and open it in the Map Viewer: 
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On the left toolbar, > Create app > Choose ArcGIS Story Maps, as follows: 
 

 
 
 
Alternative A method to start a story map:   Go to https://storymaps.arcgis.com > New Story > Add map. 
Alternative B method to start a story map:   Go to https://www.arcgis.com > use the app launcher 3x3 
grid symbol > select ArcGIS StoryMaps (note:  the position of the storymaps tool in the App launcher 
may be in a different part of the list of apps). 

https://storymaps.arcgis.com/
https://www.arcgis.com/
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[4b].  Insert the following items into your story map before your embedded map appears. 
 
[Title] 
How walkable is your community? 
 
[Start with a short introduction or a subtitle] 
A survey and map showing the degree of pedestrian friendliness of your community. 
  
[Add cover image or video:] 
One of the photographs in the downloaded set associated with this lesson, or your own photo. 
 
[Byline] 
This should default to your name. 
 
In upper right > Edit > Story Settings > set date on cover to date of last update > Done. 
 
In upper right > Design > Enable “navigation” and “credits” sections. 
Then:  Theme:  Select a theme that you think is best for your walkability story map. 
 
Go back to editing your story map: 
 
[+ > Text] as shown: 
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“The General Theory of Walkability explains how, to be favored, a walk has to satisfy four main 
conditions: it must be useful, safe, comfortable, and interesting.” 
― Jeff Speck, Walkable City: How Downtown Can Save America, One Step at a Time. 
 
Make the text italic, or use “quote” style text. 
 
[+ Text:  Paragraph] 
Walkability is the degree to which pedestrians, including those in wheelchairs, on bicycles, scooters, and 
in any other non-vehicle mode, feel safe and able to traverse their community. Whether one wants to 
walk in a community depends on many factors, such as social norms, safety, personal preferences, and 
other factors. This study focuses on the physical challenges or lack of challenges that pedestrians face.  
For pedestrians using wheelchairs or pushing strollers, walkability can also be influenced by curb cuts, 
stairs, or obstacles on the sidewalk. 
 
[+ Separator] 
 
[+ Text:  Header 1] 
What is the walkability on a street or path in your own community?  Submit your own point using the 
link below: 
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[+ Text:  Button] 
Text in button:    Click to submit a survey point. 
Link in text:   Find the URL for your own Survey123 about walkability and insert the link here.  Or, use 
the author’s survey here:  https://survey123.arcgis.com/share/bc909b23e0de418b85f48a8f86a3a229  
 
Notes:  (1)  You could, alternatively, use + Text, Paragraph, Large:  And link to text. 
(2) You could, alternatively, Use + > Embed, and embed your survey in your story map. 
 
[+ Separator] 
 
[Paragraph] 
The results of this survey, with data gathered from pedestrians around the world, can be visualized on 
the map below. 
 
All of the above items should appear before your map appears.  Your map should appear next.    If your 
map did not appear, you could open a separate tab in your browser and go to www.arcgis.com > Sign in 
if necessary > search for your ArcGIS Online map showing the results of your walkability survey.  Once 
you find the map, to make it easier to find later, under the thumbnail, click “Add to Favorites” as shown: 

 
 
Then, you could use + Map > search for, find, and embed your map, here. 
 
Or, you could use + Map and use the author’s web map, here:  
https://www.arcgis.com/apps/mapviewer/index.html?webmap=6cdc3d07021945b4baa5944fdd4b6966 
  
Go back to your browser tab where you are editing your story map. 
 
Overwrite the default map caption with the following text:  Map showing walkability survey points.   
Your map should look like this, below.  Your users will be able to interact with it. 
 

https://survey123.arcgis.com/share/bc909b23e0de418b85f48a8f86a3a229
http://www.arcgis.com/
https://www.arcgis.com/apps/mapviewer/index.html?webmap=6cdc3d07021945b4baa5944fdd4b6966


 

Connecting Surveys, Maps, and Apps   -:-       Author:  Joseph J. Kerski, PhD GISP, Esri -:-    Page 19 of 44 
 

 
 
At the top of your story map, check to make sure your story map that you are creating is auto-saving 
and is in draft.  It should be!  But it is always a good idea to check: 
 

 
 
The following content in your story map should be inserted after the embedded map. 
 
[Embed] 
Add a link to your Dashboard.  Make sure the dashboard URL is a generic ArcGIS URL and not one that 
includes the ArcGIS Online organization name.    Or use the author’s dashboard:  
https://www.arcgis.com/apps/dashboards/350dc87a18984a0fb2d3713924d8e77b 
 
Change the dashboard caption to:  Walkability survey responses:  Dashboard.  
 
When done, the dashboard should be embedded into your storymap, as shown below. Your users will 
be able to interact with it.  
 

https://www.arcgis.com/apps/dashboards/350dc87a18984a0fb2d3713924d8e77b
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[Heading 1] 
Would you say the following location is walkable?  
 
[image] 
Use the Colorado #1 image (or your own image). 
 
[Heading 2] 
Would you say the following location is walkable?  
 
[image] 
Use the Colorado image #1 (or your own image).  
 
Notice how your heading 1’s are navigation links at the top of your story map.  This is because, earlier, 
you set these navigation links in the design settings zone. 
 
[Video] 
Add “Walking in a Pedestrian Unfriendly Place” video in New Jersey by the author, Joseph Kerski at this 
URL:  https://youtu.be/wEmZiDv7BjM   The video should appear as embedded content in your story 
map, as shown below: 

https://youtu.be/wEmZiDv7BjM
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[Separator] 
 
[4c]  Edit the ending section: 
 
Scroll down to the credits heading section at the end: 
Story Map by < your initials > using lesson provided by Joseph Kerski, Esri, as an introduction to 
Survey123, web maps, dashboards, and story maps. 
 
Go to Content – and replace with “All” 
Go to Attribution – and replace with your name. 
 
In your story map’s content item page in your ArcGIS Online organization, add some additional 
metadata. 
 
[4d].  When satisfied, preview your story map, test it, publish, and share.  The author’s story map is 
here:  https://storymaps.arcgis.com/stories/f3ddbff14e7f47dba398ab5114bf751f  
 
Congratulations on your good work!   You have created a field survey, a web map, a dashboard, and a 
story map.   Consider sharing your story map with others in your organization or beyond so they can see 
your good work.     
 
● 
 
Now that you have created a basic field survey, web map, dashboard, and story map, let’s dig a little 
deeper into some intermediate functionality of each of these tools. 
 
Part 5:  Creating a field survey using the Survey123 AI Assistant.  
 
The Survey123 assistant uses a large language model (LLM) to help you design surveys from a human-
like conversation.   Ask the assistant what type of survey you want to create. When the draft survey is 
ready, ask the assistant to bring it into the Survey123 web designer. You can modify the survey in the 

https://storymaps.arcgis.com/stories/f3ddbff14e7f47dba398ab5114bf751f
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web designer before publishing it.   The assistant is built on rapidly evolving technology and this feature 
is undergoing continual improvement.  

[5a].  First, enable the assistant by doing the following: 
 

1. Go to Survey123 > Organization tab at the top above the green bar: 
2. In the green bar, > Settings 
3. In the tabs along the left side, > Extensions 
4. Access and enable the > Survey123 assistant there. 

 

 

 
Per the documentation, the Organization page in the Survey123 website only appears, and thus you will 

only be able to make changes there, if you are an administrator of your organization or a user in the 

organization with a role that includes the Organization website privilege. 

[5b].  Start a new Survey > Blank Survey > Get Started > In the lower left of the design screen > 

Survey123 assistant: 

https://doc.arcgis.com/en/survey123/get-started/organizationsettings.htm
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After clicking on Assistant > Continue > in the blank bar at the bottom of the start screen, enter this 

phrase:   

Create a walkability pedestrian survey --- as shown below: 
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Review the sentences.   At the time of this writing, 10 questions were created > Re-do with the following 

text prompt:  Generate a walkability survey with a map > At the time of this writing, this resulted in 11 

questions with a place-holder for the two map questions.  After you review these questions, > Generate.  

Compare this survey against the survey you created earlier from scratch.   

[5c].  After generating the survey, you should be in the ArcGIS Survey123 design mode.  Once there, fill 

out metadata, naming the survey Walkability Survey from Gen AI (or some variation of your choosing).  

Adjust the map questions by changing the basemaps to basemaps of your choice (use 2 different 

basemaps for your 2 different maps) and adjust the map to be at a scale zoomed to your own 

community (or where you plan to collect data). 

[5d].  Via the collaborate tab, under “who can submit to the survey?” > click “everyone” so everyone can 

contribute to your survey.  Under “what can submitters do?” > Click “only add new records.”    

[5e].  Via the survey URL, collect a few points into this survey, or use the author’s survey on: 

https://arcg.is/0yLue4  

[5f].   Experiment with rules in Survey123:  Select a primary question and click the Set rule icon    

 

In the Set rule dialog box, specify the answer choice (the If field) and the related conditional 

question (the Show field). Click OK.   

https://arcg.is/0yLue4
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Test your survey form with the rule in place.  

Congratulations!  You have expanded your knowledge of Survey123.  Remember that additional survey 

tools are continually being added, such as the sketch-a-polygon capability which was recently used to 

survey, “Where is the American Midwest”, as explained here.  And for even more capability, you can use 

Survey123 Connect with Excel. 

Part 6:  Perform spatial analysis on your mapped data. 
In Part 2, you created a map from your survey data.  Now you are ready to perform some spatial analysis 
on the data you mapped.  Spatial analysis is what sets GIS apart from “just mapping.” 
 
[6a]. Go to your content and folder in the ArcGIS Organization where you have been working.  After you 
have collected a few points into your survey from Part 1 above, do the following:  Select the walkability 
survey for workshops feature service.  This should contain your points collected in your Part 1 survey.  
Open the feature service in the Map Viewer.  Or, use the author’s feature service, on:   
https://www.arcgis.com/home/item.html?id=8dc2ab2d09d74d0d890e6dd7ed6c4e84 
  
Zoom on your map to the community in which you are collecting the data at the present time.  
 
[6b]  Use labels > set the label to Pedestrian Friendly or Unfriendly?  Observe the results. 
 
[6c].  Use Styles > Choose Attributes > make a point map symbolized by the Rate the walkability field.   
Choose an appropriate symbol and color ramp. 
 
[6d]  Use Filter > Filter to visualize all the pedestrian unfriendly locations as deemed by the survey 
respondents, as follows: 

 

https://www.esri.com/arcgis-blog/products/survey123/mapping/midwest/
https://www.arcgis.com/home/item.html?id=8dc2ab2d09d74d0d890e6dd7ed6c4e84
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Observe the resulting patterns. 
 
[6e].  Save your map in the appropriate folder (where your other data is located) with a name such as 
Walkability Map for Workshops with Analysis. 
 
[6f].  Use Aggregation > Enable Clustering > experiment with the clustering settings: 
 

 
 
Zoom out and observe the results of the clustering.  Example result: 
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Under Label > access the expression builder > New Expression > access the </> tool: 

 
 Change the line return to be as follows: 

 

return label + " features" 
 
Done > Observe the resulting modified labels from the above expression on your map. 
 
[6g].  Using label features > label filter, see if you can determine how to label your pedestrian friendly 
points in a different label style than your un-friendly points, as shown below: 
 

 
 
[6h].  Insert a chart:  Pie chart:  Pedestrian Friendly or Unfriendly.   
 
[6i].  Run the Aggregate points analysis tool, to count the number of points within polygons or bins, 
using 500 m square polygons with the processing extent as the “display extent”, as follows: Analysis > 
Aggregate points: 
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Connecting Surveys, Maps, and Apps   -:-       Author:  Joseph J. Kerski, PhD GISP, Esri -:-    Page 29 of 44 
 

 
Assess the results of your aggregate points layer.   It should look similar to the graphic below.  Click on 
the legend tool to determine what information you now have.  Save your map again. 
 

 
 
Access > Analysis > History > Messages:  How many credits did your aggregate points consume? (when 
the author ran the tool, it was 0.038 credit). 
 



 

Connecting Surveys, Maps, and Apps   -:-       Author:  Joseph J. Kerski, PhD GISP, Esri -:-    Page 30 of 44 
 

[6j]  Run Find Hot Spots tool with these parameters:  Input layer:  Walkability survey feature layer. Hot 
spot settings:  Point counts, hexagon cells; where points are possible:  Draw sketch around your study 
area as a bounding rectangle. Enrichment data:  Do not use divide by.  Result layer:  hotspot analysis or 
some other suitable name.  Environment settings:  Same as (your zoomed in) display extent:  > Run. 
 
Assess the results of your hotspot layer.  Make the hotspot layer semi-transparent as shown below. 
Compare it visually and the information about its attributes to your earlier aggregation results.     
 

 
 
[6k]  Run Enrich Layer:  This tool uses the power of web GIS and location-specific web GIS data services 
to “add to” or enrich the data in your maps.  Enrich:  Input Features:   Hotspot analysis.  Enrichment 
Data > 2023 Total Population > Add > Browse all variables and add “2023 Median Disposable Income” > 
Add.  Browse Median Age > under 2023 Income by age, select 2023 Median Age of Householder > Add.  
You should have 3 selected variables in the upper right ‘bin’ of the Data Browser > Select > Back in your 
ArcGIS Online session > Result Layer:  Provide an output name with “Enriched Layer” in the title, save in 
the appropriate data folder > Environment settings > processing extent:  Display Extent > Run.  
 
Examine your enriched layer.  Change the Style of your enriched layer to a bivariate map showing 
median disposable income and total population (both 2023) as shown below.  Filter the income to only 
show cells where the median disposable income is greater than 0: 
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See if you can change the style of the hotspot analysis so that you only see the outlines, underneath 
your bivariate enriched layer, so that you will see the grid used for the enrichment layer, as follows: 
 

  
 
Congratulations!  You have expanded your knowledge of the analysis tools inside ArcGIS Online.  

Remember that there are many other vector tools (such as mean center, standard deviational ellipse, 

count overlapping features, and more) and raster tools inside ArcGIS Online as well. 

Part 7:  Adding intermediate elements to your Dashboard. 
In Part 3, you built a basic dashboard from your survey data, which allows you and others to quickly 
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visualize your survey results in a series of maps and graphs.  Now you are ready to use some 
intermediate level dashboard tools for even more capability and insight.  
Open your dashboard from Part 3.  Go to Save > Save As > Give your new dashboard the same title with 
the addition of the word “Intermediate” after the original title.  Now you will have your original 
dashboard and the version you are working on now for an intermediate “deeper dive”. 
 
[7a]  Add these to your map settings:  Map > Settings:  Add Basemap switcher, compass, and line 
scalebar > Done > Observe the changes that you have made on your dashboard. 
 
[7b]  Stack the 2 pie charts and the indicator at the right so that the user can arrow to each of them, as 
shown: 

 
 

 

 
When done, unstack, if you prefer the unstacked appearance. 
 
[7c]  Create a mobile view for your dashboard that will work well on a mobile device:  Start on the left> 
View, as follows: 
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Create a mobile view containing these elements: 
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Save your dashboard! 
 
[7d].  Add list > select your feature service > under List:   insert the word “Site:” before the field/objectid 
as follows: 
Site: {field/objectid}    Your list should look similar to the following: 
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Under General > Title > enter:  Sites: 
Under Actions > Zoom > enable the walkability map, as shown, so your map will zoom to the site you 
select in the list: 
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[7e]  Add > a characteristics List:   Sort by:  Tick all the characteristics that describe the site, as follows; 
 

 
 
>  Observe the changes you just made to your dashboard with your new list.  Click on several 
sites and observe the behavior of the map. 
   

[7f].  Modify your characteristics list.  Select the list in your dashboard and > Configure. 
1. Instead of picking the layer as the source, > Data expressions > New data expression. 
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2. Insert the following code (you will update the highlighted parts shortly – it is from this sample): 
// Reference layer using the FeatureSetByPortalItem() method. 
var portal = Portal('https://www.arcgis.com') 
var fs = FeatureSetByPortalItem( 
    portal, 
    'd10b9e8dbd7f4cccbd0a938a06c586e9', 
    0, 
    ['Report_road_condition'], 
    false 
); 
 
// Create empty array for features and feat object 
var features = []; 
var feat; 
 
// Split comma separated hazard types and store in dictionary.   
for (var feature in fs) {  
    var split_array  =  Split(feature["Report_road_condition"], ',')  
    var count_arr = Count(split_array)  
    for(var i = 0; i < count_arr; i++ ){  
        feat = { 
            'attributes': { 
                'split_choices': Trim(split_array[i]) 
            } 
        } 
        Push(features, feat); 
}} 
 
// Empty dictionary to capture each hazard reported as separate rows.  
var choicesDict = { 
    'fields': [ 
        { 'name': 'split_choices', 'type': 'esriFieldTypeString'}],  
    'geometryType': '', 
    'features': features 
};  
 
// Convert dictionary to featureSet.  
var fs_dict = FeatureSet(choicesDict);  
 

// Return featureset after grouping by hazard types.  
return GroupBy(fs_dict, ['split_choices'],  
       [{ name: 'split_count', expression: 'split_choices', statistic: 'COUNT' }]); 
 

3. Replace the layer ID (the first yellow highlight - d10b9e8dbd7f4cccbd0a938a06c586e9) in the 
code with your layer id OR the one from your instructor: 8dc2ab2d09d74d0d890e6dd7ed6c4e84 

4. Replace the field name (second and fourth yellow highlight – Report_road_condition) in the 
code with your field name: _3_tick_all_characteristics_tha   

https://github.com/Esri/arcade-expressions/blob/master/dashboard_data/SplitCategories(PieChart).md
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a. Note that you might want to rename that field before publishing your survey to give it a 
better alias! 

5. Fix all the comments in the code from hazards to walking characteristics (3rd yellow highlight – 
split comma separated hazard) [not required to fix the comment, but it is a best practice not to 
leave in outdated comments). 

6. Click Done in “Edit data expression”.  You may need to run the expression.   
a. In your dashboard, the list should look similar to this: 

 
b.  Go back to List > configure the list.   

7. In the Data tab, > set “Sort by” to “split_count” and set it to “sort descending” 
8. In the List tab, scroll down to > to > Line item template and replace with: {field/split_count} 

{field/split_choices}  
9. Still in the list tab, scroll down even more > set the Line item icon to None (as it doesn’t really 

mean much here).  Or, leave it alone, your choice. 
10. You will get a list, but with your displays of the attributes not very clean. Thus > Add spaces 

before {field/split_count} and between the field/split_count and Field/split_choices. 
11. When done, examine your results, which should look something like this below: 
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12.  Save your dashboard! 
 
[7g].  In the list you created, note the _ underscores.  Use Arcade code to make the appearance better, 
as follows: 
  

1. Go to your dashboard > the list you just created  > Configure the list. 
2. In the “List” tab >  “Enable” for advanced formatting unless it is already enabled.  If it is already 

enabled, you will see the code. 
3. Replace all _ (underscores) with spaces in your choices string and return the updated string as a 

new variable, as follows: 
var newLabel = Replace($datapoint.split_choices, '_', ' ') 
 
return { 
  textColor: '', 
  backgroundColor: '', 
  separatorColor:'', 
  selectionColor: '', 
  selectionTextColor: '', 
  attributes: { 
    label: newLabel 
  } 
} 

4. Scroll down:  Update the List’s Line item template (in the same tab as the advanced formatting, 
but further down) to use your new variable: 
{field/split_count} {expression/label} 
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You list should appear similar to the following: 

 

➢ Done.  Return to your dashboard.  It should look similar to this, below: 
 

 
 
[7h].  Add > Category selector at the top of your dashboard. Configure it as follows:  Select your feature 
layer. Then > Data > Grouped Values > Select Rate the Walkability of this site > Sort by “rate the 
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walkability”.  Then under Selector > Dropdown, allow multiple, under General, under > “No selection” > 
All.  Actions:  Filter Walkability survey for workshops feature layer > Done.   
 

 
 
Test your category selector: 
 

 
 
Save your dashboard. 
 
[7i].  Click on points in your map and notice that nothing happens.  You will, in this step, change this so 
that actions take place:   Configure Map > Layer actions > enable “show pop-up” and “select feature”.   
Save.  Go back to your dashboard, click on your map, and observe the differences.    
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Next, go to Map > Configure > Layer actions again > Flash:  Enable walkability map.  Filter:  Chart rate the 
walkability:  Enable.   Scroll down:  Allow rectangle multiple selection tool > Done.  Go back to your 
dashboard:   Use new multiple selection tool and select a few points.  Note what happens to the “rate 
the walkability” chart when you select several points.  The chart’s data now only reflects the information 
for the points you have selected: 
 

 
 
Save your dashboard.  Well done! 
 
For even deeper dives: 
 
Configure ArcGIS Dashboards to display selected feature attributes, attachments, and location on the 

map:  https://support.esri.com/en-us/knowledge-base/how-to-configure-arcgis-dashboards-to-display-

selected--000026591  

Getting started with Arcade in ArcGIS Dashboards: https://www.esri.com/arcgis-blog/products/ops-

dashboard/real-time/getting-started-with-arcade-in-arcgis-dashboards/ 

Pushing the limits of Arcade in dashboards:  https://www.esri.com/arcgis-blog/products/ops-

dashboard/real-time/pushing-the-limits-of-arcade-in-dashboards/ 

How to easily copy a dashboard to see the code for it, learn from it, and use it for your own 

dashboard:  https://esriurl.com/dashcopy. 

 
Part 8:  Adding intermediate elements to your StoryMap. 
In Part 4, you created a story map with text, images, video, map, and dashboard. Now you are ready to 

do some intermediate work on your story map.    

https://support.esri.com/en-us/knowledge-base/how-to-configure-arcgis-dashboards-to-display-selected--000026591
https://support.esri.com/en-us/knowledge-base/how-to-configure-arcgis-dashboards-to-display-selected--000026591
https://www.esri.com/arcgis-blog/products/ops-dashboard/real-time/getting-started-with-arcade-in-arcgis-dashboards/
https://www.esri.com/arcgis-blog/products/ops-dashboard/real-time/getting-started-with-arcade-in-arcgis-dashboards/
https://www.esri.com/arcgis-blog/products/ops-dashboard/real-time/pushing-the-limits-of-arcade-in-dashboards/
https://www.esri.com/arcgis-blog/products/ops-dashboard/real-time/pushing-the-limits-of-arcade-in-dashboards/
https://esriurl.com/dashcopy
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[8a].  Make a duplicate copy of your story map > Edit Story > Duplicate.  Now you are editing a duplicate 

of your original.  Change the title slightly to indicate that this is your intermediate version of your story 

map. 

[8b].  Below your first embedded dashboard, insert your new intermediate dashboard into your story 

map and compare it to your introductory dashboard, and note the progress you are making! 

 

[8c].  Add map > New Express Map:  Zoom map to location where you are collecting walkability points.    

Add a few points with an image.  Then, add a few ordered points and draw an arrow to connect them, as 

shown below: 

 

 

[8d].  Below your new express map > Insert > Map Tour:  Insert Map > Find your walkability feature layer 

and insert it.  Configure the elements (photos, text, points) as desired.  When done, test the navigation 

and experience on your map tour; it will look similar to the following: 

 

 

Save your story map. 

[8e].  Go to Design > Theme > Featured themes gallery and observe the choices.  Choose one of them. 
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Test and make observations.  Then > Design your own theme.  Choose colors, typography, buttons, 

quotes, and more.  Publish, and then apply your own theme to this story map.   Save your story map. 

[8f]. Now that you have 2 story maps > Go to storymaps.arcgis.com and observe your stories.   Go to 

collections > New Collection > create a new collection.  Into your collection place your 2 story maps.  

When done, open your collection, make observations, and make any modifications you see fit. 

Congratulations!  You have taken a deeper dive with surveys, maps, dashboards, and story maps!  And I 

encourage you to go even deeper with these and other ArcGIS tools and data! 

● 


