hellski

VRML export issue

Discussion created by hellski on Feb 15, 2013
Latest reply on Feb 25, 2013 by Carrie_davis-esristaff
Hey everyone,

when I try to export simple Tins (or documents which contain Tins) from my ArcScene to .wrl the export fails. Please see my example:

I have the following table (xlsx):
X Y hoehe
28 -2 0
-2 -2 0
28 48 0
-2 48 0

I import it into ArcScene through add xy data. Than I build a Tin from it using hoehe as height field (There is no difference between using python or going manually):
arcpy.CreateTin_3d(r'C:\Users\aasen\Documents\ArcGIS\Default.gdb\floor_tin', '#', "'Tabelle1$ Events' hoehe Mass_Points <None>", 'DELAUNAY'

Doing this I get a nice flat Tin. Now I'm exporting the Tin with 3D -> VRML where I select the options:
Indent text [check]
visible layers [check]
GeoVRML [no check]
Center [no check]
ElevationGrid [check]
JPEG Quality = high

The resulting VRML (attached as unbenannt.rar) is incomplete.
freeWRL is giving me the following error code:
FreeWRL expected library version freeWRL version 1.22.12, got libfreeWRL version
 1.22.12...
windir path=[C:\Windows]
get_current_dir returns[C:/Users/aa/Desktop/]
argv[0]=C:\Program Files (x86)\freeWRL\freeWRL\freeWRL.exe
argv[1]=C:\Users\aa\Desktop\Unbenannt.wrl
posixlycorrect=[(null)]
starting createWindow32
wm_create
starting createcontext32
got hdc
Depth Bits = 24
created context
made a window
resize_GL
showed window
updated window - leaving createwindow
opengl version=3.3.0
ERROR: Expected a closing brace after fields of a node; at: "400
             diffuseColor     1,000 1,000 1,000
             emissiveColor    0,000 0,000 0,000
             shininess        1,000
..."error in parser_fieldValue by call 2
Expected sfnode Value for a fieldtype! at: "400
             diffuseColor     1,000 1,000 1,000
             emissiveColor    0,000 0,000 0,000
             shininess        1,000
..."ERROR: Expected a closing brace after fields of a node; at: "400
             diffuseColor     1,000 1,000 1,000
             emissiveColor    0,000 0,000 0,000
             shininess        1,000
..."error in parser_fieldValue by call 2
Expected sfnode Value for a fieldtype! at: "400
             diffuseColor     1,000 1,000 1,000
             emissiveColor    0,000 0,000 0,000
             shininess        1,000
..."ERROR: Expected a closing brace after fields of a node; at: "400
             diffuseColor     1,000 1,000 1,000
             emissiveColor    0,000 0,000 0,000
             shininess        1,000
..."ERROR:Expected "]" before end of MF-Value at: "400
             diffuseColor     1,000 1,000 1,000
             emissiveColor    0,000 0,000 0,000
             shininess        1,000
..."ERROR: Expected a closing brace after fields of a node; at: "400
             diffuseColor     1,000 1,000 1,000
             emissiveColor    0,000 0,000 0,000
             shininess        1,000
..."ERROR:Expected "]" before end of MF-Value at: "400
             diffuseColor     1,000 1,000 1,000
             emissiveColor    0,000 0,000 0,000
             shininess        1,000
..."ERROR: Expected a closing brace after fields of a node; at: "400
             diffuseColor     1,000 1,000 1,000
             emissiveColor    0,000 0,000 0,000
             shininess        1,000
..."ERROR:Expected "]" before end of MF-Value at: "400
             diffuseColor     1,000 1,000 1,000
             emissiveColor    0,000 0,000 0,000
             shininess        1,000
..."ERROR: Expected a closing brace after fields of a node; at: "400
             diffuseColor     1,000 1,000 1,000
             emissiveColor    0,000 0,000 0,000
             shininess        1,000
..."ERROR:Expected "]" before end of MF-Value at: "400
             diffuseColor     1,000 1,000 1,000
             emissiveColor    0,000 0,000 0,000
             shininess        1,000
..."ERROR: Expected a closing brace after fields of a node; at: "400
             diffuseColor     1,000 1,000 1,000
             emissiveColor    0,000 0,000 0,000
             shininess        1,000
..."Parsing complete, but have unrecognized data at end of input:"400
             diffuseColor     1,000 1,000 1,000
             emissiveColor    0,000 0,000 0,000
             shininess        1,000
             specularColor    0,000 0,000 0,000
 ....)?¤"Parser Unsuccessfulresize_GL


Thank you so much for your help!
(This thread can also be found on http://gis.stackexchange.com/questions/52049/vrml-export-issue-arcscene)

Attachments

Outcomes