3 Replies Latest reply on Apr 25, 2011 3:33 AM by timothy_hales-esristaff

    Toolbox not working

    geonetadmin
      Original User: skydiver_jim

      I can't get the toolboxes to work on ArcMap 10.  They were fine on install, but recently I had a rouge spyware called WINDOWS DIAGNOSTIC.  I got rid of the virus; however, there are some quirky things with the machine (Windows 7 Professional 64-bit).  ArcMap comes up fine, and I can add data, zoom and pan around, etc.  But when I click on I click on the toolbox window, there's just a picture of a toolbox ( empty_toolbox.jpg).  I can search for a tool, and it will give me returns (data_management.jpg), but if I click on the tool, nothing happens.  A lot of the tools summaries are not available.  If I hold my mouse over a tool and click on the item description, Arcmap will hang.  If I bring up ArcCatalog, click search, and then just click on the word "tools" the list of toolboxes come up (tool_list.jpg).  I'm at a loss for what to do.  TIA for any suggestions.
        • Re: Toolbox not working
          timothy_hales-esristaff
          Hi Jim,

          Before doing a complete uninstall/reinstall, I would suggest resetting you registry keys and application data. With all ArcGIS programs closed, reset your application data and restart ArcMap. If that does not work, reset your registry key then run ArcMap.


          App Data Reset:
          Windows Explorer > Local Disk > Users > Your User Name > App Data (this will be hidden unless the hidden files and folders have been turned on) > Roaming > rename the "ESRI" folder to "ESRI_old"

          Registry Keys Reset:
          Start Menu > Run, type 'regedit' and click OK. Expand HKEY_CURRENT_USER > Software > and rename 'ESRI' to 'ESRI_Old'.


          *Note: these will reset all toolbars and spatial database connections in ArcMap/Catalog (they will still be saved in the '_old'> ArcCatalog folder. Copying the "ArcCatalog.gx file into the new application data path will restore the connections)


          I hope that helps.

          -Timothy
          • Re: Toolbox not working
            skydiver_jim
            Timothy,

            Thanks for the suggestions.  I tried both, but still had the same results.  I removed and reinstalled, and things seem to be working fine now.

            Thanks again.
            • Re: Toolbox not working
              timothy_hales-esristaff
              Timothy,

              Thanks for the suggestions. I tried both, but still had the same results. I removed and reinstalled, and things seem to be working fine now.

              Thanks again.


              Great!  Glad to hear tings are working now.

              -Timothy