11 Replies Latest reply on Mar 16, 2012 10:54 AM by fitzin1234

    Building routes doesn't work

    geonetadmin
      Original User: fitzin1234

      Hey,

      I already set up 2 locations (distribution centers), vehicles and imported the orders into an routing folder. However, when I press the "build routes" button, a window opens saying that 2 route locations cannot be found on the network (namely my 2 depots) and so the operation cannot proceed (screenshot attached).

      Furthermore, before this windows opens, another window opens saying that the constraints concerning "Max Orders" and "Weight Capacity" cannot be met. For that purpose I have to say, that I don't have a "Max Orders" constraint in my VRP and therefore I entered any large number as "Max Order".

      Screenshots of both windows are attached.

      Would be great if you could help me..

      Best regards, Andrea
        • Re: Building routes doesn't work
          byagrich-esristaff
          Hi Andrea, we'll try to help you out here.

          First, can you provide the addresses of your 2 depots and let us know what dataset you're using?  If those depots aren't geocoded correctly then ArcLogistics will not know how to calculate a route to a point not identified on the network.  We can check to see if these are located in some area which may cause problems.

          As for your max orders issue, this is pretty odd.  You have a value of over -1 billion for max orders which is impossible when entering a value in the UI.  When vehicles are created, they have a default max order value of 25.  Could you look at properties for your vehicles and see what is listed for max orders?  The weight constraint looks like it's working perfectly well, you lack capacity to deliver all of the orders based on weight.

          You mentioned that you entered any large number as 'max order', what exactly does this mean?  Max orders is a numeric property of a vehicle.  It can deliver 1, 20, 100 etc. orders in any given day.
          • Re: Building routes doesn't work
            geonetadmin
            Original User: fitzin1234

            Ok, now I'm quite sure the network dataset is the problem... I couldn't find an appropriate network dataset and so I used a network dataset of the tutorial data (I think Rhode Island) just to try if the software works. Where can I find a network dataset of Europe, in particular of Austria? Can you send me one?
            In addition I was not sure which locator to use. There are several different locators for Austria..

            All the addresses I'm using are in Austria (mainly Vienna and also Lower Austria and Burgenland). In particular, the address of the first depot is Litfassstra�?e 8, 1031 Wien and the address of the second depot is Arbeitergasse 50, 2333 Leopoldsdorf.

            I'm currently not at university so I cannot check what is listed for max orders. But as I don't have a max order constraint for the vehicles I think I entered a large number (e.g. 10.000) so that this factor is not considered for the route building. (I hope you understand what i mean, but it's a little hard for me to explain it in english :-)
            What value do you recommend me to enter for max orders?

            Thanks!
            • Re: Building routes doesn't work
              fitzin1234
              I want to add that the 2 depots and all the orders are geocoded and are also displayed in the map...
              • Re: Building routes doesn't work
                geonetadmin
                Original User: byagrich

                This is confusing, if you used Rhode Island tutorial data, it definitely would not have locators for Austria but you mention that all locations appear geocoded.  Also, you mention seeing multiple locators for Austria.  Does it look like my attached screenshot?  If you could send some screenshots of how you setup your project, it might help.  In general, you're just going to need to make sure you have a map document (.mxd), network dataset, and locator which has coverage for your area.  Unfortunately, I can't help you obtain those. You'd have to have someone at your University obtain it through an Esri distributor.

                As for orders, I think your solution is fine.  10,000 is a lot though.
                • Re: Building routes doesn't work
                  fitzin1234
                  As map template I used "European Thematic Maps" (this is the only one I have for Europe, but there is also a World map)
                  The problem is the network dataset... The only *.nds documents I have are those from the tutorials (Redlands and Ireland). (screenshot 3)
                  However, I have a lot of different locators (see screenshot) in the folder Arc Logistics - Street data - NTEU2011_R1 - Locators.

                  As you can see in the second screenshot, the depots are geocoded and appear in the map. Same with the orders..
                  • Re: Building routes doesn't work
                    geonetadmin
                    Original User: byagrich

                    Ok, this is all starting to make more sense.  It seems you do have an Esri release European dataset, this is good! 

                    Browse to wherever that NTEU2011_R1 folder is.  In there, you should see an .mxd folder, a locators folder, and a streets.rs file among many other .sdc, .sdi, etc. files.  Create a new project and point to the .mxd, appropriate AUT .loc file (or Default European), and use the streets.rs file as the network dataset.  This should get you running, see attached screenshot.
                    • Re: Building routes doesn't work
                      fitzin1234
                      I've exactly done what you told me to. Nevertheless it doesn't work as you can see in the screenshot. It says "Netword dataset path is invalid"
                      • Re: Building routes doesn't work
                        geonetadmin
                        Original User: byagrich

                        It appears to be a problem with the dataset licensing.  Go into the .mxd folder and double click the AL_NTEU_11R1.sdlic file to manually install the license.  If it states that the license already exists, choose Yes to overwrite.
                        • Re: Building routes doesn't work
                          fitzin1234
                          Yes, now it works. Thank you sooo much!!!
                          • Re: Building routes doesn't work
                            geonetadmin
                            Original User: byagrich

                            Very happy to hear it!
                            • Re: Building routes doesn't work
                              fitzin1234
                              Also the route building is working now :-)
                              Thank you really very much!