4 Replies Latest reply on May 7, 2012 6:12 AM by geonetadmin

    Advanced Labeling for stretched renderer with Hi/Low values

    geonetadmin
      Original User: gallysam

      Hope someone can help me on this cause it is driving me mad..

      I have some raster data (ArcGis Grids) and need to represent them on stretch display using advanced labeling, Problem is that I cant make it work using modified max and min values. I wonder if that is a limitation of the program or it it a bug.
      After setting proper render (Min/Max) I go to labeling and let the program create the labels and intervals...ll goes well( first screenshot).
      [ATTACH=CONFIG]13990[/ATTACH]
      Then If I change the values on the min/max, set the labels and all I get is the old min max color ramp with no labels ( You can see the result in second image). If I go and insert the legend I get the color ramp with the value brakes but not labels. In the table of contents I can see there are empty labels but can´t edit the text on them. Found somewhere that there was a bug related to this but I´m on ArcGis10 SP3 and according to SP info that bug was fixed
      [ATTACH=CONFIG]13989[/ATTACH]
        • Re: Advanced Labeling for stretched renderer with Hi/Low values
          gallysam
          No one?? please guys I really need to solve this. Or at least know if it�? only me who's sufering...
          • Re: Advanced Labeling for stretched renderer with Hi/Low values
            geonetadmin
            Original User: jbswain

            For your workflow, the because of the manner at which the values are generated with the 'Generate' button, you will have to make the max/min have the decimals or it will not include them.  The wizard will simply do the direct math.  Since your first first value is 5 and specify 10 values the algorithm will then create the values as a straight division.  I entered decimals and then the output would have decimals. 

            From what I understand about your complaint, you want the same types of divisions of classes, but since you are altering the minimum and max value the classes appear to be generalize.  Your old class interval was roughly 1.1 and the new one is 1, hence the discrete values.  Because of the values you are inputting and the way that the algorithm works, I would call what you are seeing as expected behavior. So to avoid the loss of decimal, then make the interval value of 1.1 (if that is desired).  What you are doing is making the data discrete and then specifying a discrete interval without a decimal in the label.
            • Re: Advanced Labeling for stretched renderer with Hi/Low values
              gallysam
              For your workflow, the because of the manner at which the values are generated with the 'Generate' button, you will have to make the max/min have the decimals or it will not include them.  The wizard will simply do the direct math.  Since your first first value is 5 and specify 10 values the algorithm will then create the values as a straight division.  I entered decimals and then the output would have decimals. 

              From what I understand about your complaint, you want the same types of divisions of classes, but since you are altering the minimum and max value the classes appear to be generalize.  Your old class interval was roughly 1.1 and the new one is 1, hence the discrete values.  Because of the values you are inputting and the way that the algorithm works, I would call what you are seeing as expected behavior. So to avoid the loss of decimal, then make the interval value of 1.1 (if that is desired).  What you are doing is making the data discrete and then specifying a discrete interval without a decimal in the label.


              THX for your reply, bot I think it is not what I'm asking for... I do understand why the classes are different and I actually want them to be in increments of 1. The problem is more with the generated color ramp. As you can see on the screen shots I posted after i´ve changed the min/max values, the labels disappear. I'm not complaining about the way the algorithm calculates the divisions, the problem is that I´m loosing the labels generated by that algorithm
              • Re: Advanced Labeling for stretched renderer with Hi/Low values
                geonetadmin
                Original User: jbswain

                I apologize for misunderstanding the original question, I thought you were missing the 'decimals' not missing just in the table of contents.  There is a bug report, NIM67106, that is currently assigned to a developer for this behavior.  If you would like to be added to the incident then please log a Support Incident, as always the more users on the bug report, the more visibility it has for development to consider it to be fixed.