mlou

Build Failed - Failed to register Add-in

Discussion created by mlou on Sep 7, 2010
Latest reply on Aug 8, 2017 by tofv
I have been going through the Add-in walkthrough and when I try to Build I get an error "Failed to register Add-in 'CustomUIElements.esriAddIn'"

This is the Build Output:
------ Build started: Project: CustomUIElements, Configuration: Release Any CPU ------
C:\WINDOWS\Microsoft.NET\Framework\v3.5\Csc.exe /noconfig /nowarn:1701,1702 /errorreport:prompt /warn:4 /define:TRACE /reference:C:\ArcGIS\DeveloperKit10.0\DotNet\ESRI.ArcGIS.ArcMapUI.dll /reference:C:\ArcGIS\DeveloperKit10.0\DotNet\ESRI.ArcGIS.Carto.dll /reference:C:\ArcGIS\DeveloperKit10.0\DotNet\ESRI.ArcGIS.Desktop.AddIns.dll /reference:C:\ArcGIS\DeveloperKit10.0\DotNet\ESRI.ArcGIS.Display.dll /reference:C:\ArcGIS\DeveloperKit10.0\DotNet\ESRI.ArcGIS.Framework.dll /reference:C:\ArcGIS\DeveloperKit10.0\DotNet\ESRI.ArcGIS.Geometry.dll /reference:C:\ArcGIS\DeveloperKit10.0\DotNet\ESRI.ArcGIS.System.dll /reference:"c:\Program Files\Reference Assemblies\Microsoft\Framework\v3.5\System.Core.dll" /reference:"c:\Program Files\Reference Assemblies\Microsoft\Framework\v3.5\System.Data.DataSetExtensions.dll" /reference:C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\System.Data.dll /reference:C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\System.dll /reference:C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\System.Drawing.dll /reference:C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\System.Windows.Forms.dll /reference:C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\System.Xml.dll /reference:"c:\Program Files\Reference Assemblies\Microsoft\Framework\v3.5\System.Xml.Linq.dll" /debug:pdbonly /filealign:512 /optimize+ /out:obj\Release\CustomUIElements.dll /target:library Properties\AssemblyInfo.cs ZoomToLayerButton.cs AddGraphicsTool.cs Config.Designer.cs
Compile complete -- 0 errors, 0 warnings
CustomUIElements -> C:\VisualStudio\Projects\CustomUIElements\CustomUIElements\bin\Release\CustomUIElements.dll
Successfully created Add-in "CustomUIElements" -> 'C:\VisualStudio\Projects\CustomUIElements\CustomUIElements\bin\Release\CustomUIElements.esriAddIn'.
esriRegAddin.exe "C:\VisualStudio\Projects\CustomUIElements\CustomUIElements\bin\Release\CustomUIElements.esriAddIn" /s
C:\Program Files\MSBuild\ESRI\ESRI.ArcGIS.AddIns.targets(125,5): error : Failed to register Add-in 'CustomUIElements.esriAddIn'.
Done building project "CustomUIElements.csproj" -- FAILED.
========== Build: 0 succeeded or up-to-date, 1 failed, 0 skipped ==========


Software:
Visual Studio 2008
ArcGIS 10
XP Pro 32bit

I didn't use the sample data, just followed the walkthrough and ran Build when it told me to ("Installing the custom button and tool" section)

Any ideas on what's happening?

Cheers,
Mike.

Outcomes