28 Replies Latest reply on Jun 15, 2012 11:57 AM by RAluvilayil-esristaff

    ArcMap 10 hangs at Initializing Application

    bdaigle
      I just received a copy of ArcGIS 10 through the home use program.  I was able to install the software and authorize my license without issue, but I can't seem to get ArcMap up and running.  The initial popup gets past the "Initializing License" phase, but hangs on the "Initializing Application" phase. 

      So far, I have checked to make sure my computer meets the minimum requirements, uninstalled and reinstalled, repaired my installation.

      My OS is Vista Home Premium and I have an ArcInfo Single Use license (This is how it is authorized).   ArcCatalog opens just fine, but ArcMap, ArcGlobe and ArcScene all hang at the same place.

      Any suggestions???
        • Re: ArcMap 10 hangs at Initializing Application
          vsfoote
          Bill,

          It sounds as if you may be having the same OpenGL 2.0 compliance issue with your graphic card that many of us experienced early in the ArcGIS 10 release cycle. Especially if you installed the Data Interoperability extension.  I'd suggest that to start you verify that you have the latest OpenGL driver for your video card.  The link to the RealtechVR OpenGL Extensions Viewer provided in this earlier forum post should be of help.

          [INDENT]http://forums.arcgis.com/threads/7731-Problem-with-ArcMap-10-hanging?p=26650#post26650[/INDENT]

          I'd also suggest you read through that thread and note the other issues and the debug processes folks have used to work through the problem with the "hang at initialization" stage.  As I recall, XTools needed an update if installed, and Data Interoperability extension was OpenGL > 2.0 dependent, and that problems with ArcGIS user registry settings, or a corrupt default.gdb in you user profile folder were all potential causes of ArcMap hangs on initialization.

          Stuart
          • Re: ArcMap 10 hangs at Initializing Application
            bdaigle
            Thank for the tip.  I think I can safely say my current problem has to do with a corrupt default.gdb.  When I start up arcmap, it create about 10 default.gbd files every second.  I'm not sure how long this would go on for.  What now?  I don't think the "Home Use" license includes any type of technical support, so I'm not sure what recourse I have.
            • Re: ArcMap 10 hangs at Initializing Application
              vsfoote
              Bill,


              If need be we can walk you through doing an ArcCatalog folder connection to your My Documents\ArcGIS directory and creating of an empty file geodatabase as suggested by ESRI support to use to replace a corrupt default.gdb as mentioned in Jeff Roland's 29 Sep post (#41) in the "Problem with ArcMap 10 hanging" thread.

              But to start, my suggestion would be to try the registry edit steps of the 16 Sep post (#39) by Brent Stevener to clobber the HKEY_CURRENT_USER\Software\ESRI\ArcMap keys. 

              And then to also delete these ESRI ArcGIS related folders created in your user account:

              For XP
              [INDENT]C:\Documents and Settings\<your user name>\My Documents\ArcGIS\*.*
              C:\Documents and Settings\<your user name>\Application Data\ESRI\*.*

              [/INDENT]

              or for  Windows Vista or 7
              [INDENT]C:\Users\<your user name>\My Documents\ArcGIS\*.*
              C:\Users\<your user name>\AppData\ESRI\*.*

              [/INDENT]

              Assuming there is no corruption with the installation, these directories and contents should all be correctly recreated for your account from the templates in the ArcGIS Program files directory when you next load ArcGIS, including creation of a new default.gdb.

              Log off and reboot the system.

              When you log back on launch ArcMap, your ArcGIS profile and configurations should be rebuilt.

              Exit from ArcMap.

              With windows explorer, browse the My Documents\ArcGIS folder for you account to see if the default.gdb was created.

              Launch ArcMap again, and exit again.

              Check in the My Documents\ArcGIS folder again to see if just the single default.gdb is there.

              If just the one copy, and ArcMap is opening and closing without the hangs you may be set.

              Launch ArcMap again and try to add some data to the map, save the map and close ArcMap. Navigate to the My Documents\ArcGIS folder where the .mxd should have just been saved. Double click on the .mxd to launch ArcMap and bring up the map.

              Use ArcCatalog to create a new file geodatabase and a couple of feature classes. And then add to the map in ArcMap. Save the map and exit ArcMap and ArcCatalog. Reopen ArcMap from a template or as a new empty map. If it opens--and still only one default.gdb you should be set.

              Stuart
              • Re: ArcMap 10 hangs at Initializing Application
                vsfoote
                Hi Laurene,

                Wow, that suggestion was kind of from left field. But, I just read the NIM061743 ( http://resources.arcgis.com/content/nimbus-bug?bugID=TklNMDYxNzQz ) suggesting that on Windows 7 problems with MSXML4 impacting ArcGIS 10 Desktop as cause of the multiple default.gdb problem.  Welcome news for folks if the fix is as simple as an install or update of MSXML4.

                Assume it also works for Vista based users. 

                Bill, try Laurene's suggestion first!

                Stuart
                • Re: ArcMap 10 hangs at Initializing Application
                  gdevans1949
                  I'm on my second round of this problem. Updating the MSXML file worked the first time. All was well for about a month then, whack!!!, the same issue. So far uninstalling and reinstalling the MSXML 4.0 SP3 file has failed. When I look in the System32 file I see MSXML 3 and 6 along with 4.0. I've also deleted the user profile I was using and created a new one...no luck.

                  This is the first time I've heard about the registry edits and deleting files from My Documents and appdata. Thanks for the heads up on that one. I'll give it a try
                  • Re: ArcMap 10 hangs at Initializing Application
                    gdevans1949
                    Follow up to yesterday's post: the final resolution was a System Restore.
                    • Re: ArcMap 10 hangs at Initializing Application
                      ecarlsson
                      I am having the same issues, but no problems with the default, have tried to repair the program, have the right graphics card and have downloaded msxml4 SP3. Nothing seems to help arccatalog opens fine but not acrmap. This is getting annoying, any suggestions?

                      Erica
                      • Re: ArcMap 10 hangs at Initializing Application
                        janekaiser
                        Hi There,
                        I am running the evaluation version of ArcGIS 10 (SP2) on a brand new windows 7 machine. I had the same issue with ArcMap hanging however I did not have the creation of multiple GDB files. After much messing around it ended up being "Google toolbar" that I had accidentally installed that seemed to be causing the problem. After I uninstalled Google toolbar my ArcMap worked!
                        • Re: ArcMap 10 hangs at Initializing Application
                          Lakeland_GIS
                          Our City Engineer was having a similar issue with ArcMap freezing at start up. We uninstalled and reinstalled ArcGIS and still had the same problem - the software would lock up when opening an ArcMap session. After some investigation we realized some software had been installed on his workstation without his knowledge. The software in question was Microsoft Security Essentials and once this was uninstalled through the Control Panel>Add/Remove Programs, ArcMap began working correctly again. He is running ArcGIS v.10 SP2 on Windows XP. Hope this helps.

                          Josh
                          • Re: ArcMap 10 hangs at Initializing Application
                            shanemjensen
                            This thread started in November 2010. It is now November 2011. I have the same problem(s).
                            • Re: ArcMap 10 hangs at Initializing Application
                              jkaboaf
                              This worked for me!! I've got ArcGIS 10 and am running Windows 7. I got the corrupt MSXML error, ref. #KB38523. I went to the website and installed msxml4 SP3. Arc started right up. I am very grateful. What a relief to get my GIS back up and running. Thanks!!

                              Jennifer

                              Bill

                              Download and install msxml4 SP3 and see if that resolves your issue.

                              http://www.microsoft.com/downloads/en/details.aspx?FamilyID=7f6c0cb4-7a5e-4790-a7cf-9e139e6819c0&displaylang=en

                              thanks
                              Laurene
                              • Re: ArcMap 10 hangs at Initializing Application
                                marshflynn
                                This just happened to me too.  Up-to-date V10.  Using Windows 7 (automatic updates on).  Used ArcMap a few days ago.  Froze on 'initializing license' today.  Only difference for me was ArcCatalog did not open either, froze at splash screen.  My solution: killed ArcMap and ArcCatalog using 'Task Manager'.  Deleted all files beneath 'My Documents\ArcGIS', deleted all files beneath 'users\me\appdata\local\esri' AND 'users\me\appdata\roaming\esri'.  Rebooted computer and both worked again.  I didn't have anything in 'default.gdb' anyway.  So had nothing to do with OpenGL or didn't have to mess with registry.  At least that is my story.......
                                • Re: ArcMap 10 hangs at Initializing Application
                                  bshauger
                                  I was running just fine with Arcmap 10 student version.  One day it hung up "initializing Application."  I thought back as to whether I installed any Windows 7 updates or changed anything.  The only thing I had done recently was remove a installation DVD for my dsl modem.  When I put it back in the drive, Arcmap came up fine.  If I remove it before starting ArcMap it hangs.  I just installed Arcmap 10 SP4 and now I get the KB38523 error message if I don't have a cd or dvd installed in my disc drive.  I've tried the steps in the notice but nothing solves the problem.  Any idea?
                                  • Re: ArcMap 10 hangs at Initializing Application
                                    bshauger
                                    Well, I've tried everything in this thread including re-installing ArcMap 10.  Nothing helps.  If I don't have a cd/dvd in my drive ArcMap hangs at the Initializing Application message on the splash screen.  And the disk has to be my netgear DSL modem install disk for some very strange reason.  Since I have a student version I can't get help from ESRI.  This is very frustrating.
                                    • Re: ArcMap 10 hangs at Initializing Application
                                      RAluvilayil-esristaff
                                      Well, I've tried everything in this thread including re-installing ArcMap 10.  Nothing helps.  If I don't have a cd/dvd in my drive ArcMap hangs at the Initializing Application message on the splash screen.  And the disk has to be my netgear DSL modem install disk for some very strange reason.  Since I have a student version I can't get help from ESRI.  This is very frustrating.


                                      Hi Bruce,

                                      Rename the ArcGIS Folder to ArcGIS_Old in your C:\Users\user account\Documents\ .
                                      Install MSXML 4.0 Service Pack 3 (Microsoft XML Core Services)-( Link: http://www.microsoft.com/en-us/download/details.aspx?id=15697 ) and Microsoft XML Core Services 4.0 Service Pack 3 (KB973685)-( LINK: http://www.microsoft.com/en-us/download/details.aspx?id=7434 ).
                                      Re-boot the machine. Try to launch ArcMap 10.
                                      • Re: ArcMap 10 hangs at Initializing Application
                                        afkobussen
                                        Well, I've tried everything in this thread including re-installing ArcMap 10.  Nothing helps.  If I don't have a cd/dvd in my drive ArcMap hangs at the Initializing Application message on the splash screen.  And the disk has to be my netgear DSL modem install disk for some very strange reason.  Since I have a student version I can't get help from ESRI.  This is very frustrating.


                                        Bruce,
                                        I had exactly the same problem this week - I installed a new netgear DSL modem and am having the same problem. I've tried uninstalling and reinstalling everything (include all different versions of MSXML). Did you find anything that eventually worked for you?
                                        • Re: ArcMap 10 hangs at Initializing Application
                                          Leandermen
                                          Hello

                                          I don't know if it can helps but sometimes ArcMap hangs at initializing when you worked with Map Documents stored in a network path (i.e. \\10.15.xxx.xxx\folder\Mapdocument.mxd) or you work with SDE Geodatabases. I don't know why but it takes a long time between initializing application and loading document. In that case, ESRI Knowledge Base has an article where you can find the Registry Path of the recent file list and when i deleted the folder it solves the problem!. I suggest you if you work inside multiple networks (VPN, field support, etc) to clean the recent file list.

                                          Greetings

                                          Leandro Zamudio (CHL)
                                          Geographer - GIS Specialist
                                          • Re: ArcMap 10 hangs at Initializing Application
                                            graeme
                                            I've noticed another cause of ArcMap 10 hanging as it tries to start on Windows 7 but it only applies if you are using license borrowing.

                                            If you have borrowed a license and have left the web address of the license server you are borrowing from in the ArcGIS Administrator, then moved your laptop somewhere with access to the web but no longer to the license server (perhaps it has been placed back behind a firewall), then ArcMap 10 appears unable to start.

                                            Three ways around this appear to be:

                                            1. Make the license server reachable again

                                            2. Disconnect access to the web

                                            3. Open ArcGIS Administrator and remove the name of the license server



                                            Recently, I was at a venue where 1 (due to firewall) and 3 (due to permissions) were not available but fortunately it was more important for me to have access to ArcMap than the web so 2 worked!  The drawback was of course that I could no longer reach ArcGIS Online but in this instance that was survivable.

                                            I'm curious whether anybody else has seen this and/or whether it is a known bug.  I was using ArcGIS Desktop 10.0 SP5 and Windows 7 and the problem manifested itself on 3-4 laptops before I realized that disconnecting from the web provided a workaround.

                                            - Graeme
                                            • Re: ArcMap 10 hangs at Initializing Application
                                              bg3075
                                              We have the same issue, accessing map documents stored on a network drive, after upgrading from ArcGIS 10 SP3 to SP5 (ArcGIS License Manager, Server, ArcSDE, Desktops). I have followed the suggestions in post#4 / #16 (except did not have the same registry key as in post #4, so did not delete any key). Still not repaired. But, our case is a bit different, as our ArcGIS Desktop hangs after "Initializing Application" on "Loading Document". It must have something to do with ArcSDE, though, as we have also recently moved it to another server (and database connection, therefore), but this usually only results in dead links to the SDE database upon opening the map document. Though, we are able to open map documents stored on the network without links to ArcSDE.

                                              Is there possibly some permissions to a network directory that we must reset on the (ArcSDE) server?
                                              • Re: ArcMap 10 hangs at Initializing Application
                                                bg3075
                                                I opened a tech support inquiry with ESRI on our issue, and was solved (by James M.) by adding multiple lines to the end of the windows hosts file (C:\WINDOWS\system32\drivers\etc\hosts). These consist of the same ip address already in the last line of the file, on each line below, with a space after the ip address, followed by the name of the previous ArcSDE server name (only one additional single line if only had one previous installation, but we had multiple connections in the past).

                                                We had to do this due to our desktops accessing a floating license, so we could not unplug from the network and load ArcMap.
                                                • Re: ArcMap 10 hangs at Initializing Application
                                                  mariathors
                                                  I had the same problem. After going through all the suggestions here I uninstalled something called browser manager and babylon toolbar ArcMap works without problem.

                                                  Hi There,
                                                  I am running the evaluation version of ArcGIS 10 (SP2) on a brand new windows 7 machine. I had the same issue with ArcMap hanging however I did not have the creation of multiple GDB files. After much messing around it ended up being "Google toolbar" that I had accidentally installed that seemed to be causing the problem. After I uninstalled Google toolbar my ArcMap worked!
                                                  • Re: ArcMap 10 hangs at Initializing Application
                                                    maxbohnet
                                                    I've noticed another cause of ArcMap 10 hanging as it tries to start on Windows 7 but it only applies if you are using license borrowing.

                                                    If you have borrowed a license and have left the web address of the license server you are borrowing from in the ArcGIS Administrator, then moved your laptop somewhere with access to the web but no longer to the license server (perhaps it has been placed back behind a firewall), then ArcMap 10 appears unable to start.

                                                    Three ways around this appear to be:

                                                    1. Make the license server reachable again

                                                    2. Disconnect access to the web

                                                    3. Open ArcGIS Administrator and remove the name of the license server



                                                    - Graeme


                                                    I had the same problem with a borrowed license.
                                                    For me, Tip No 3 helps:
                                                    When i borrow the licence, i connect to the license server (within the network of my university or connexting through a VPN-Client).
                                                    Then, i have to delete the entry "27000@my.license.server.de" in the the ArcGIS Administrator.
                                                    If i keep this entry in the ArcGIS-Administrator, ArcGIS takes half an hour to start.
                                                    If i delete it, it starts rather quickly.
                                                    When i want to return the license, or when i want to renew the borrowed license, i have to re-entry the license-server-information in the ArcGIS-Administrator, return or borrow the license and then remove the entry again.

                                                    Thanks für this valuable hint!

                                                    Max
                                                    • Re: ArcMap 10 hangs at Initializing Application
                                                      bubbahey25
                                                      there are a few bugs with VPN and license manager. I'll see if I can find relevant ones.
                                                      • Re: ArcMap 10 hangs at Initializing Application
                                                        bubbahey25
                                                        Bug NIM-053680
                                                        http://support.esri.com/en/bugs/nimbus/TklNMDUzNjgw

                                                        Bug NIM-060359
                                                        High Latency/Low Bandwidth connections prevents license borrowing, license distribution, and/or enterprise activation/return.
                                                        http://support.esri.com/en/bugs/nimbus/TklNMDYwMzU5

                                                        Try the steps in NIM-060359 - that has worked for me.
                                                        • Re: ArcMap 10 hangs at Initializing Application
                                                          TMontefusco-esristaff
                                                          Bubba is correct, only I advise increasing FLEXLM_TIMEOUT to  20,000,000
                                                          • Re: ArcMap 10 hangs at Initializing Application
                                                            orion4130
                                                            I had the exact same problem, and followed all of the suggested steps. In the end it turns out that the problem was the the hosting service that I used to connect to my office remotely via VPN.

                                                            If you use a secure VPN connection to connect to another server remotely (in my case, it was "SonicWall SSLVPN"), try disconnecting that service at the time of startup for ArcMap.