9 Replies Latest reply on May 19, 2014 10:09 AM by bubbahey25

    Installation error 1935

      I'm trying to install ArcGIS Desktop 10 on Windows 7 Professional (32 bit).
      Near the end of the installation it hang with following error:

      "Error 1935. An error occurred during the installation of assembly 'Microsoft.MSXML2R,processorArchitecture="x86",publicKeyToken="6bd6b9abf345378f",version="",type="win32"'. Please refer to Help and Support for more information. HRESULT: 0x800736FD. assembly interface: IAssemblyCacheItem, function: Commit, component: {5617BF49-9195-4C35-B9AD-F8D165DE25BB}"

      I have already tried to:

      - Start Windows without any unnecessary services and processes running (neither antivirus)
      - Run setup with Administrative Privilege
      - Clean registry with cclener

      On this machine i have installed Visual Studio 2008, Visual Studio 2010

      Any suggestions ?
      Thank's in advance
        • Re: Installation error 1935
          Do you have this key in the registry?


          Key: RegistrySizeLimit

          If so, rename it to old_RegistrySizeLimit. Reboot, then try the installation again.


          • Re: Installation error 1935
            If I can make an observation, on a heavily loaded system such as this (with VS 2008, VS 2010 and an ArcGIS 10 install attempt) if the suspected cause of the 1935 errors is a registry resource issue (the 0x800736FD result), wouldn't it make more sense to suggest maxing out the registry size.

            As I understand it, if the RegistrySizeLimit key isn't set or is removed/renamed as recommended, the registry size defaults to 80% of pagefile size at the start of install and additional install attempt could then still fail due to registry resource constraints.

            I would suggest that following the recommendations of Jim Tochterman's Windows 7 installation solution from Aug 2009, to set the RegistrySizeLimit key to "0xffffffff", e.g. 4GB, would be a more generally successful work around.

            For convenience, the thread from the old forum is here:


            p.s.  Also documented in this ESRI KB Article 37477
            • Re: Installation error 1935
              Great !
              Configuring 0xfffffff on that registry key does the trick !
              I installed ArcGIS succesfully now.

              Thank you

              Andrea V.
              • Re: Installation error 1935
                I have the same error. However, The registry key does not exist in my registry.  I have win7x64, tried searching for the key but does not exist and I did try to make the key myself, but still, I am receiving the same error.  I really do not want to format my PC and start fresh. 

                Any ideas?
                • Re: Installation error 1935
                  There are quite a few things that show up as Microsoft Installer 1935 errors. Aaron Stebner provides useful explanations here:

                  The recommendation to adjust the registry size using the \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\RegistrySizeLimit DWORD(32-bit),
                  is made to recover from and will proactively prevent exhaustion of registry resources during a MS Installer based installation--thereby avoiding a 1935 error.  It is especially needed for heavily configured systems where multiple releases of MS Visual Studio and other applications with heavy registry footprints (ArcGIS, Adobe CS) are being undertaken. Unfortunately, exhaustion/unavailability of registry resource is enough to stop the installation throwing the 1935 errors--even though the system volume and registry may as a result be dynamically resized.

                  From Windows Vista on the RegistrySizeLimit has reportedly been deprecated, however there appear to remain installer components where an OS request for dynamic resize of the sysvol pagefile results in creation of the RegistrySizeLimit stanza. If the stanza is present and it is not set to the 0xffffffff value--it has probably been generated during an automated pagefile resize operation.

                  Here are my notes for editing the registry setting correctly:
                  Using... "Run as administrator" method launch a new command prompt. And then enter "regedit.exe". A new window "Registry Editor" will open with full administrative permissions.

                  Be careful with any changes as they are irreversible. A full backup is a good idea and simply performed from the editors File --> Export menu selecting the Export Range "All" button and saving it to a safe location. A recovery essentially imports this data back into the registry database but that's another topic.

                  So with the registry open in regedit, navigate to the Local Machine hive System\CurrentControlSet key. A series of left mouse selections on each "plus" to open each descending key. As you descend the current position will be reflected at the lower left satus bar of the window. You'll end up at Computer \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet. In the lefthand panel you see a listing of keys --Control, Enum, Hardware Profiles, Policies, services under CurrentControlSet. Point and select the Control key. The right-hand panel will now populate with a number of registry values. Look for a stanza named "RegistrySizeLimit" it would be a blue icon of type REG_DWORD.

                  If it is there you'll "Right mouse" select and "modify" its HEX value. If it doesn't exist you'll create it and enter a HEX value for it. Either way the size limit of the registry will be set to 4GB, entered as a HEX value of "ffffffff"--eight "f"s. The decimal value will show as "4294967295", easier to enter the "f"s.

                  If it is not there, create a new DWORD--"Right mouse" anywhere in the right hand panel. A "New" menu will open, point at it and a sub-menu of selections will open. Point select the "DWORD(32-bit) Value". A new stanza will appear and should show with type of REG_DWORD. It should be highlighted and ready to take a name--enter "RegistrySizeLimit". Now set its value with a "Right mouse" select and "modify". An Edit DWORD window will open, and in the value data field enter the eight "f"s. Click "OK" to save and close it. The data column value should now show"0xffffffff (4294967295)" At that point its done, just exit the registry editor.

                  Please verify that you've correctly set a DWORD(32-bit) to 0xffffffff as above.

                  Additional things to do on your Windows 7 x64 loaded system before continuing your ArcGIS install:

                  [INDENT]1) from Start --> Accessories --> Command Prompt : right mouse and  "run as administrator"

                  [INDENT]   a) run SFC /SCANNOW

                     b) reboot!

                     This will repair any Windows Resource Protection components (so you don't have to reinstall!)
                  2) disable your AV before starting the install

                  3) download and install the MSXML4 sp3, not present by default in Windows 7 and correct XML4 handling is needed for ArcGIS, and is helpful for other applications that may not correclty function with only MSXML6.
                  [INDENT] http://www.microsoft.com/downloads/en/details.aspx?FamilyID=7f6c0cb4-7a5e-4790-a7cf-9e139e6819c0&displaylang=en
                  Reboot following install.

                  4) using Stebner's  .NET Framework Setup Verification Tool
                  and verify your .NET framework installs--very important for Windows 7. If all checks out--proceed. Otherwise you'll need to repair the Windows 7 support for any .NET framework that is faulting--v2.0 --> v4.0

                  5) Finally, back to your ArcGIS install--don't allow the Autorun of the installer. Rather use Windows Explorer and be sure to right mouse on the ESRI.exe installer from the DVD (or mounted .ISO image) and select "run as administrator" to deal with the UAC issues.  Run each component from the ESRI installation panel.

                  If you still have problems with the install post back and we'll walk you through doing the install from the "run as administrator" command line with msiexec.exe /i and /l*v logging. So at that point, when you have the installer logs, you can pin down the exact issues with the install on your system.

                  1 of 1 people found this helpful
                  • Re: Installation error 1935
                    Hey ,  the installation worked out perfectly when I disabled the .NET Support features in the Custom Installation. My OS is Windows 7 Pro.

                    I hope it has been helpful.
                    • Re: Installation error 1935
                      Thanks vsfoote!  This worked out perfect...
                      • Re: Installation error
                        hay good evening,. i have just instal my arcgis but i have found some problem.
                        for first install i find for installer information that "ArcGis 10.1 for desktop requires Microsoft.NET Framework 3.5 sp1 or equivalent
                        please see the installation guide for more information",.if i find some problem like this what should i do?? anyway i have windows 7
                        • Re: Installation error 1935
                          Yes, go to Control Panel, Programs and Features. Click Turn Windows features on or off.

                          Next, look for Microsoft .NET Framework 3.5.1 - if you see a blue box, not all components are installed. Click the plus sign and select all components. Once installed, try again.
                          1 of 1 people found this helpful