union77

SDE 10 Upgrade Fails:ORA-29855: error occurred in the execution of ODCIINDEXCREATE

Discussion created by union77 on Dec 14, 2010
Latest reply on Mar 7, 2011 by orivero
Can anyone help me with the following error that I'm getting when attempting to upgrade to ArcSDE 10:

Executing: UpgradeGDB "Database Connections\SDE_DC.sde" NO_PREREQUISITE_CHECK UPGRADE

Start Time: Tue Dec 14 14:27:27 2010

Paused the database for upgrade.
There are no other active connections.
User has privileges required to upgrade.
Connected RDBMS instance is not setup for ST_GEOMETRY configuration. [Unable to determine current version of ST_SHAPELIB
The latest ST_GEOMETRY and dependent libraries need
to be copied to the correct software location.
Please consult ArcSDE for Oracle Installation Guide
for further details.
]
Could not upgrade multiple schema or database instance. [The master geodatabase contains user schema geodatabases which should be upgraded separately after the master geodatabase is upgraded.
Id Version Instance
---- ------- -------------------
1 9.3.0 SDE_QC

Running Pre-Requisite check (C:\ESRI\Desktop10.0\ArcCatalog\SDE_DC.sde).

Instance supports XML type.

ArcSDE server tables and stored procedures are up to date.

Underlying DBMS error [Layer not found] [Error executing PL/SQL Block db_stgeom_create_index


ORA-29855: error occurred in the execution of ODCIINDEXCREATE routine

ORA-04063: package body "SDE.SPX_UTIL" has errors

ORA-06508: PL/SQL: could not find program unit being called: "SDE.SPX_UTIL"] Underlying DBMS error [Error executing PL/SQL Block db_stgeom_create_index

ORA-29855: error occurred in the execution of ODCIINDEXCREATE routine

ORA-04063: package body "SDE.SPX_UTIL" has errors


ORA-06508: PL/SQL: could not find program unit being called: "SDE.SPX_UTIL"]

Unpaused the database.

Failed to execute (UpgradeGDB).

Failed at Tue Dec 14 14:27:39 2010 (Elapsed Time: 12.00 seconds)

Outcomes