AnsweredAssumed Answered

Problems with steady connection between Server and Databases

Question asked by leonhard.stoeckle_AED_SICAD on Jun 19, 2017
Latest reply on Jun 19, 2017 by leonhard.stoeckle_AED_SICAD

Hi there,

I installed ArcGIS Server 10.5, Portal for ArcGIS 10.5, Data Store 10.5 and two Oracle 12 Databases. I use an 32bit and an 64bit instant client to connect the oracle databases. I also have all of the above recently updated.
I set up Portal, Server an databases on a virtual machine with Windows 2012 R2.
I recently set up a Portal for ArcGIS on this machine. I mainly work on a second machine with Windows 8.1 and ArcMap 10.5 and an 32bit oracle instant client. (for Publishing etc.)

Recently (last 2 or 3 weeks) I noticed that my Server just looses connection to the databases. After restarting it has problems to find my data store and the databases (managed and unmanaged). When it finds those it has all of its system services stopped. (e.g. publishing)

Even worse often enough, after I get the services to run the connection to the databases gets lost again.

Most of the time I don't even get my Server to connect to my databases.
The first two or three ours a day everything works just fine. After that the server just becomes really unreliable and becomes a constant struggle to get the connection right. Even if I get a connection it just stays for a few minutes and looses it again while for example publishing. Sometimes the Server also just stops running, so I have to start it up again.

 

I'm really out of ideas. I tried updating the programs, restarting databases, data store, server and even portal in every imaginable order.

Thanks in advance!
Leonhard

Outcomes