26 Replies Latest reply on Apr 14, 2014 2:37 AM by ghost_general

    Installing ArcGIS for AutoCAD Issues

    rxndft
      I just downloaded "ArcGIS for AutoCAD", installed as per instructions.
      Started AutoCAD Map 2011, typed NETLOAD, an ESRI dialog box appeared briefly.
      I am assuming it has been loaded, but I do not see any ribbon or menu for ArcGIS.
      Am I missing something?
        • Re: Installing ArcGIS for AutoCAD Issues
          AThunuguntla-esristaff
          I just downloaded "ArcGIS for AutoCAD", installed as per instructions.
          Started AutoCAD Map 2011, typed NETLOAD, an ESRI dialog box appeared briefly.
          I am assuming it has been loaded, but I do not see any ribbon or menu for ArcGIS.
          Am I missing something?


          Hi,

          Are you able to see any other ribbon tabs like Home, Insert, Annotate, Parametric etc?
          • Re: Installing ArcGIS for AutoCAD Issues
            ashleydia
            I am on 2011 too. Were you prompted to navigate to the .dll? Everytime I start CAD, I have to type in the netload command then navigate to the ArcGISForAutoCAD.dll.
            • Re: Installing ArcGIS for AutoCAD Issues
              AThunuguntla-esristaff
              I am on 2011 too. Were you prompted to navigate to the .dll? Everytime I start CAD, I have to type in the netload command then navigate to the ArcGISForAutoCAD.dll.


              Hi Ashley,

              You can automatically load ArcGIS for AutoCAD when you start AutoCAD using an acad.lsp file or running a (.scr) script at startup.

              1. Using an acad.lsp file
              You can create an acad.lsp file if you regularly use ArcGIS for AutoCAD. When you start AutoCAD, it searches the support file search path for an acad.lsp file. If an acad.lsp file is found, it loads the contents of the file.
              The following snippet demonstrates how to load ArcGIS for AutoCAD from an acad.lsp file.
              (command "_ribbon")
              (command "netload" "C:\\Program Files\\ArcGIS for AutoCAD 250\\ArcGISForAutoCAD")

              2. Using a (.scr) script file
              A script is a text file with one command on each line. You can run a script at startup or during a work session by typing SCRIPT at the command prompt.
              The following snippet demonstrates how to load ArcGIS for AutoCAD from a script file.
              _ribbon
              netload
              "arcgisforautocad.dll"

              Note:
              To run a script at startup in the Run dialog box use the switch /b.
              For example: ACAD /b MyStartupScript.
              • Re: Installing ArcGIS for AutoCAD Issues
                ashleydia
                Thanks Anant,
                That did seem cumbersome. Glad there is a faster way to get to work!
                • Re: Installing ArcGIS for AutoCAD Issues
                  rxndft
                  Hi,

                  Are you able to see any other ribbon tabs like Home, Insert, Annotate, Parametric etc?


                  Thank you for responding to my issue. Sorry I haven't gotten back to you sooner.
                  Today I tried using NETLOAD again and it worked today.
                  I am looking forward to utilizing this new feature.
                  Thank you again, have a good day.
                  • Re: Installing ArcGIS for AutoCAD Issues
                    AThunuguntla-esristaff
                    Hello,

                    I have the same problem:
                    I type NETLOAD, and then nothing happens. I see the ribbons, but there's only the normal ones.
                    I have AutoCAD 2010.
                    What should I do?

                    Thanks a lot


                    Hi,

                    Can you post more details - like configuration?
                    • Re: Installing ArcGIS for AutoCAD Issues
                      ckrtsqrl
                      I am having the same issue in civil 3d 2010. When I run netload I get the following message:

                      Cannot load assembly. Error details: System.BadImageFormatException: Could not
                      load file or assembly 'ArcGISForAutoCAD, Version=250.0.0.0, Culture=neutral,
                      PublicKeyToken=null' or one of its dependencies. An attempt was made to load a
                      program with an incorrect format.
                      File name: 'ArcGISForAutoCAD, Version=250.0.0.0, Culture=neutral,
                      PublicKeyToken=null'
                         at System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase,
                      Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark,
                      Boolean throwOnFileNotFound, Boolean forIntrospection)
                         at System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase,
                      Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark,
                      Boolean throwOnFileNotFound, Boolean forIntrospection)
                         at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef,
                      Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
                         at System.Reflection.Assembly.InternalLoadFrom(String assemblyFile, Evidence
                      securityEvidence, Byte[] hashValue, AssemblyHashAlgorithm hashAlgorithm,
                      Boolean forIntrospection, StackCrawlMark& stackMark)
                         at System.Reflection.Assembly.LoadFrom(String assemblyFile)
                         at Autodesk.AutoCAD.Runtime.ExtensionLoader.Load(String fileName)
                         at loadmgd()
                      • Re: Installing ArcGIS for AutoCAD Issues
                        AThunuguntla-esristaff
                        I am having the same issue in civil 3d 2010. When I run netload I get the following message:

                        Cannot load assembly. Error details: System.BadImageFormatException: Could not
                        load file or assembly 'ArcGISForAutoCAD, Version=250.0.0.0, Culture=neutral,
                        PublicKeyToken=null' or one of its dependencies. An attempt was made to load a
                        program with an incorrect format.
                        File name: 'ArcGISForAutoCAD, Version=250.0.0.0, Culture=neutral,
                        PublicKeyToken=null'
                           at System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase,
                        Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark,
                        Boolean throwOnFileNotFound, Boolean forIntrospection)
                           at System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase,
                        Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark,
                        Boolean throwOnFileNotFound, Boolean forIntrospection)
                           at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef,
                        Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
                           at System.Reflection.Assembly.InternalLoadFrom(String assemblyFile, Evidence
                        securityEvidence, Byte[] hashValue, AssemblyHashAlgorithm hashAlgorithm,
                        Boolean forIntrospection, StackCrawlMark& stackMark)
                           at System.Reflection.Assembly.LoadFrom(String assemblyFile)
                           at Autodesk.AutoCAD.Runtime.ExtensionLoader.Load(String fileName)
                           at loadmgd()


                        Hi,

                        There is an issue with Civil 3D 2010. It is only available as a 32 bit install. Meanwhile ArcGIS for AutoCAD 32 bit cannot be installed on a 64 bit machine.

                        There is a workaround. Install 64 bit ArcGIS for AutoCAD. Install 32 bit ArcGIS for AutoCAD on a different machine. Copy the dlls from the 32 bit machine to 64 bit machine and netload the 32 bit dlls. This should work.
                        • Re: Installing ArcGIS for AutoCAD Issues
                          dekrem
                          I am having the same issue in civil 3d 2010. When I run netload I get the following message:

                          Cannot load assembly. Error details: System.BadImageFormatException: Could not
                          load file or assembly 'ArcGISForAutoCAD, Version=250.0.0.0, Culture=neutral,
                          PublicKeyToken=null' or one of its dependencies. An attempt was made to load a
                          program with an incorrect format.
                          File name: 'ArcGISForAutoCAD, Version=250.0.0.0, Culture=neutral,
                          PublicKeyToken=null'
                             at System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase,
                          Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark,
                          Boolean throwOnFileNotFound, Boolean forIntrospection)
                             at System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase,
                          Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark,
                          Boolean throwOnFileNotFound, Boolean forIntrospection)
                             at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef,
                          Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
                             at System.Reflection.Assembly.InternalLoadFrom(String assemblyFile, Evidence
                          securityEvidence, Byte[] hashValue, AssemblyHashAlgorithm hashAlgorithm,
                          Boolean forIntrospection, StackCrawlMark& stackMark)
                             at System.Reflection.Assembly.LoadFrom(String assemblyFile)
                             at Autodesk.AutoCAD.Runtime.ExtensionLoader.Load(String fileName)
                             at loadmgd()


                          I am having the same issue with Civil 3D 2010.  Any news?
                          • Re: Installing ArcGIS for AutoCAD Issues
                            AThunuguntla-esristaff
                            I am having the same issue with Civil 3D 2010.  Any news?


                            Hi dekrem,

                            Can you tell me on which OS is your Civil 3D 2010 installed?
                            • Re: Installing ArcGIS for AutoCAD Issues
                              chrisarey
                              I installed the ArcGIS for AutoCAD with no problems. However, I am trying to add an ESRI basemap from the menu and nothing happens...Is anyone having this problem? Thanks
                              • Re: Installing ArcGIS for AutoCAD Issues
                                mlefevre
                                I'm using Civil 3d 2010 on a 64-bit machine, Windows 7 and I have done the work aorund from 64-bit to 32-bit.  Which seemed to work, only when I command line NETLOAD and open the dll file the only thing that happens is the ESRI dialog box appears and just sits there churning away.  Has anyone else had this problem or know how to fix it????
                                • Re: Installing ArcGIS for AutoCAD Issues
                                  Rlittlefield
                                  I am having trouble getting ArcGIS for AutoCAD to run at startup.

                                  I am using AutoCAD 2011. I can get the ribbon to come up by typing in "Netload" into the command line and then navigating to the ".dll" file (ArcGISForAutoCAD.dll).

                                  I would like to have the ribbon be up everytime I open up AutoCAD. I have tried to follow the directions online and on the forums, but can't figure it out.

                                  I created a acad.lsp file using notepad. Inside the file I have the following: (command "_ribbon")
                                  (command "netload" "C:\Program Files\ArcGIS for AutoCAD 300\ArcGISForAutoCAD.dll")" 
                                  Now what do I do with that file? Where do I put it? I tried putting it here: "C:\Program Files\Autodesk\AutoCAD 2011\Support" but nothing happens. Do I need to move the dll file? Is the wording correct inside my acad.lsp file?

                                  A sep-by-step process of what I sould do would be great. Again, I would just like it to run automatically at start up. Thanks
                                  • Re: Installing ArcGIS for AutoCAD Issues
                                    AThunuguntla-esristaff
                                    I am having trouble getting ArcGIS for AutoCAD to run at startup.

                                    I am using AutoCAD 2011. I can get the ribbon to come up by typing in "Netload" into the command line and then navigating to the ".dll" file (ArcGISForAutoCAD.dll).

                                    I would like to have the ribbon be up everytime I open up AutoCAD. I have tried to follow the directions online and on the forums, but can't figure it out.

                                    I created a acad.lsp file using notepad. Inside the file I have the following: (command "_ribbon")
                                    (command "netload" "C:\Program Files\ArcGIS for AutoCAD 300\ArcGISForAutoCAD.dll")" 
                                    Now what do I do with that file? Where do I put it? I tried putting it here: "C:\Program Files\Autodesk\AutoCAD 2011\Support" but nothing happens. Do I need to move the dll file? Is the wording correct inside my acad.lsp file?

                                    A sep-by-step process of what I sould do would be great. Again, I would just like it to run automatically at start up. Thanks


                                    Hi Richard,

                                    Replace (command "netload" "C:\Program Files\ArcGIS for AutoCAD 300\ArcGISForAutoCAD.dll")with (command "netload" "C:\\Program Files\\ArcGIS for AutoCAD 300\\ArcGISForAutoCAD")
                                    • Re: Installing ArcGIS for AutoCAD Issues
                                      AThunuguntla-esristaff
                                      I installed the ArcGIS for AutoCAD with no problems. However, I am trying to add an ESRI basemap from the menu and nothing happens...Is anyone having this problem? Thanks


                                      Hi Chris,

                                      Can you give me more details? (Version of AutoCAD? OS? 32 or 64 bit?)
                                      • Re: Installing ArcGIS for AutoCAD Issues
                                        AThunuguntla-esristaff
                                        I'm using Civil 3d 2010 on a 64-bit machine, Windows 7 and I have done the work aorund from 64-bit to 32-bit.  Which seemed to work, only when I command line NETLOAD and open the dll file the only thing that happens is the ESRI dialog box appears and just sits there churning away.  Has anyone else had this problem or know how to fix it????


                                        Hi Mitch,

                                        Are you facing this issue with Build 300?
                                        • Re: Installing ArcGIS for AutoCAD Issues
                                          Rlittlefield
                                          Hi Richard,

                                          Replace (command "netload" "C:\Program Files\ArcGIS for AutoCAD 300\ArcGISForAutoCAD.dll")with (command "netload" "C:\\Program Files\\ArcGIS for AutoCAD 300\\ArcGISForAutoCAD")


                                          Hi Anant,

                                          Thanks for your response, however it still doesn't work. I guess the quick and easy fix to this is just placing a shortcut to ArcGIS for AutoCAD 300 on my desktop and open that everytime I want to use CAD instead of AutoCAD 2011.

                                          Just to Clarify again, I have ArcGIS for AutoCAD installed and it works fine. The only thing I can't get it to do is automatically open when I open an existing dwg file.

                                          I created an acad.lsp file using notepad. Inside that file I have the following text, "(command "_ribbon")
                                          (command "netload" "C:\\Program Files\\ArcGIS for AutoCAD 300\\ArcGISForAutoCAD")"

                                          I have that file stored here, C:\Program Files\ArcGIS for AutoCAD 300.

                                          What am I doing wrong? My thought was if I open AutoCAD 2011 either by the desktop shortcut or by clicking on an existing dwg file autoCAD would open up and the ESRI toolbar would automatically be there. Am I wrong?

                                          Thanks again.
                                          • Re: Installing ArcGIS for AutoCAD Issues
                                            ramon42
                                            Hi Anant,

                                            Thanks for your response, however it still doesn't work. I guess the quick and easy fix to this is just placing a shortcut to ArcGIS for AutoCAD 300 on my desktop and open that everytime I want to use CAD instead of AutoCAD 2011.

                                            Just to Clarify again, I have ArcGIS for AutoCAD installed and it works fine. The only thing I can't get it to do is automatically open when I open an existing dwg file.

                                            I created an acad.lsp file using notepad. Inside that file I have the following text, "(command "_ribbon")
                                            (command "netload" "C:\\Program Files\\ArcGIS for AutoCAD 300\\ArcGISForAutoCAD")"

                                            I have that file stored here, C:\Program Files\ArcGIS for AutoCAD 300.

                                            What am I doing wrong? My thought was if I open AutoCAD 2011 either by the desktop shortcut or by clicking on an existing dwg file autoCAD would open up and the ESRI toolbar would automatically be there. Am I wrong?

                                            Thanks again.


                                            I created an easier step by step method for auto loading ArcGIS for AutoCAD. See this thread : http://forums.arcgis.com/threads/39768-Auto-load-ArcGIS-for-AutoCAD-Ribbon?p=229468#post229468

                                            Cheers!
                                            • Re: Installing ArcGIS for AutoCAD Issues
                                              Rlittlefield
                                              I created an easier step by step method for auto loading ArcGIS for AutoCAD. See this thread : http://forums.arcgis.com/threads/39768-Auto-load-ArcGIS-for-AutoCAD-Ribbon?p=229468#post229468

                                              Cheers!


                                              That worked great thanks!!
                                              • Re: Installing ArcGIS for AutoCAD Issues
                                                fatimakhunsa
                                                Hi everyone!

                                                I have successfully installed arcGIS for AutoCAD but couldn't run the ESRI services and ArcGIS services.
                                                Anyone having any idea?????????
                                                • Re: Installing ArcGIS for AutoCAD Issues
                                                  AThunuguntla-esristaff
                                                  Hi everyone!

                                                  I have successfully installed arcGIS for AutoCAD but couldn't run the ESRI services and ArcGIS services.
                                                  Anyone having any idea?????????


                                                  Hi Fatima,

                                                  Can you give more details about the server you are trying to access?
                                                  • Re: Installing ArcGIS for AutoCAD Issues
                                                    vilakonemp
                                                    I am having the same issue with Civil 3D 2010.  Any news?


                                                    I have same problem with you! any suggestion from ESRI technical support? or anyone can help?
                                                    • Re: Installing ArcGIS for AutoCAD Issues
                                                      avoliseng
                                                      Hi folks,
                                                      I'm running AutoCAD 2011 on Windows 7 64-bit.
                                                      I downloaded and installed "ArcGISforAutoCAD2010_300_SP1_64.exe" and installed it.
                                                      The installation appeared to go fine.
                                                      I launched AutoCAD via the "ArcGIS for AutoCAD" start menu link.
                                                      Once AutoCAD was loaded, I issued the netload command, browsed to the "ArcGISForAutoCAD.dll" file, clocked [Open] and...nothing.
                                                      So I tried the autoload method posted above...
                                                      When I launch AutoCAD now, the AutoCAD text history window displays:
                                                      Customization file loaded successfully. Customization Group: ACAD
                                                      Customization file loaded successfully. Customization Group: CUSTOM
                                                      Regenerating model.
                                                      
                                                      Command:
                                                      AutoCAD menu utilities loaded._ribbon netload Assembly file name: D:\Program 
                                                      Files\ArcGIS for AutoCAD 300\ArcGISForAutoCAD *Cancel*
                                                      
                                                      Command: _RIBBON
                                                      Enter BACKSPACE to interrupt script.
                                                      
                                                      Command: netload
                                                      Assembly file name: "arcgisforautocad.dll"
                                                      
                                                      Command:


                                                      I see no ArcGIS splash screen, menus, pallette, nothing.
                                                      Any idea what's up?

                                                      Thanks in advance!
                                                      -Mike
                                                      • Re: Installing ArcGIS for AutoCAD Issues
                                                        warren_marcus
                                                        I have read the responses in this thread, but there still does not seem to be an answer.
                                                        I am using AutoCAD 2010, Windows 7, 34 Bit.

                                                        I have followed all the suggestions, am getting no errors but there is nothing on the ribbon at all and cannot seem to add it from somewhere either?

                                                        Any other suggestions would be appreciated.
                                                        • Re: Installing ArcGIS for AutoCAD Issues
                                                          shannon_powell
                                                          Happy Monday!

                                                          I have successfully installed the ArcGIS for AutoCAD plug-in on my Windows 7 (SP1), 64 bit office computer.  I am running 2007 version of AutoCAD.  I do have the toolbar showing.  When I click on "Add Map Service", the dialogue box comes up and then a message on the command line reads:

                                                          _ESRI_AddMap ArcGIS for AutoCAD:  Failed to register COM server.
                                                          ArcGIS for AutoCAD, Release Build 200.0.3349.25408, SP1

                                                          Any ideas of what I can do to fix this?

                                                          Thank you!
                                                          • Re: Installing ArcGIS for AutoCAD Issues
                                                            ghost_general
                                                            I have installed the ArcGIS for AUTOCAD in my AUTOCAD 2010. I have followed the netload process and I can see the dll file for ArcGIS for AUTOCAD 300. The only problem is that the toolbar is not loading in the application. I am using a 32-bit Windows 7 SP1 Lenovo laptop with processor speed of 1.66GHz and 2 GB RAM. Please help.