5 Replies Latest reply on Oct 17, 2011 12:10 PM by juan.drangstere

    Upgrade to ArcSDE 10 - Oracle 11g

    juan.drangstere
      I've been trying to upgrade to ArcSDE 10 - Oracle 11g (running in the same server Windows Server 2008 64-bit) but I've been having problems to succeed.
      The Pre-Requisite check succeeded but when the upgrade tool try to upgrade the database I just get this messenge:

      Updating ArcSDE server tables and stored procedures.
      Could not update ArcSDE server tables and stored procedures.
      Unpaused the database.
      Failed to execute (UpgradeGDB).
      Failed at Thu Oct 13 10:43:54 2011 (Elapsed Time: 9.00 seconds)


      At this moment We're trying to upgrade a copy of our production database cause this problem and that we couldn't stop our database service for a long time.

      I've looked for a log or something that could tell me what the problem is and fix it but there's nothing in the ArcSDE logs.
      Before there was a tool named checkschema but apparently it doesn't exist any more, is there a tool the could help me to find what the problem is? Any ideas?


      Thanks
        • Re: Upgrade to ArcSDE 10 - Oracle 11g
          juan.drangstere
          I found a log in TEMP with this:

          [13/10/2011 02:03:13 p.m.] Paused the database for upgrade.
          [13/10/2011 02:03:13 p.m.] There are no other active connections.
          [13/10/2011 02:03:15 p.m.] User has privileges required to upgrade.
          [13/10/2011 02:03:16 p.m.] Connected RDBMS instance is setup for ST_GEOMETRY configuration.
          [13/10/2011 02:03:16 p.m.] Running Pre-Requisite check (C:\Documents and Settings\User\ESRI\Desktop10.0\ArcCatalog\db_sde_dc.sde).
          [13/10/2011 02:03:16 p.m.] Instance supports XML type.
          [13/10/2011 02:03:16 p.m.] Checking datasets.
          [13/10/2011 02:03:20 p.m.] Checked datasets.
          [13/10/2011 02:03:20 p.m.] Checking representations.
          [13/10/2011 02:03:20 p.m.] Checked representations.
          [13/10/2011 02:03:20 p.m.] Checking domains.
          [13/10/2011 02:03:20 p.m.] Checked domains.
          [13/10/2011 02:03:20 p.m.] Checking replicas.
          [13/10/2011 02:03:20 p.m.] Checked replicas.
          [13/10/2011 02:03:20 p.m.] Checking historical markers.
          [13/10/2011 02:03:20 p.m.] Checking historical marker (DEFAULT).
          [13/10/2011 02:03:20 p.m.] Check succeeded (DEFAULT).
          [13/10/2011 02:03:20 p.m.] Checked historical markers.
          [13/10/2011 02:03:20 p.m.] Finished checking prerequisites.
          [13/10/2011 02:03:20 p.m.] Updating ArcSDE server tables and stored procedures.
          [13/10/2011 02:03:25 p.m.] Error(Check Datasets): Could not update ArcSDE server tables and stored procedures.
          [13/10/2011 02:03:25 p.m.] Unpaused the database.
          • Re: Upgrade to ArcSDE 10 - Oracle 11g
            fjones-esristaff
            Hi Juan,

            There might be more information in the %temp%\sde_setup.log or the %temp%\sdedc_Oracle.log.
            • Re: Upgrade to ArcSDE 10 - Oracle 11g
              juan.drangstere
              Thank you for the reply fojo, you were right I found this in sde_setup.log:


              [Thu Oct 13 16:31:25 2011]
              ST_Geometry Schema Owner: (SDE) Type Release: 1007
              [Thu Oct 13 16:31:25 2011] Instance initialized for ((sde)) . . .

              [Thu Oct 13 16:31:25 2011] ArcSde is already at an acceptable release:
              9.3.1 
              [Thu Oct 13 16:31:27 2011] DBMS stored procedures being created or updated...
              [Thu Oct 13 16:31:27 2011] WARNING!! Release 1023 of package sde_util found, release 1026 expected.
              [Thu Oct 13 16:31:27 2011] ERROR in creating system stored procedures.
              Error: -88
              [Thu Oct 13 16:31:27 2011] DBMS error code: 0


              [Thu Oct 13 16:31:27 2011] SDE release upgrade not completed(-1).
              [Thu Oct 13 16:31:27 2011] ERROR installing/upgrading ArcSDE, Error = -1




              But it's a WARNING, could this be the problem? Do I have to recreate the sde_util package?
              • Re: Upgrade to ArcSDE 10 - Oracle 11g
                fjones-esristaff
                Hi Juan,

                It sounds like something is out of sync. What version of client arcgis software are you using to run the upgrade? 10 final, 10 sp2, etc.? And are you going to run an application server? If so, what version of the arcsde software is on the server?

                Thanks,
                • Re: Upgrade to ArcSDE 10 - Oracle 11g
                  juan.drangstere
                  Thank you for your reply, apparently that could be the problem.
                  In the server machine is installed:
                  ArcGIS Desktop 10
                  ArcGIS Desktop 10 Service Pack 2

                  ArcSDE for Oracle11g 64bit 10



                  And in the client machine (that I'm using to run the upgrade) is installed:
                  ArcGIS Desktop 10
                  ArcGIS Desktop 10 Service Pack 1
                  ArcGIS Desktop 10 Service Pack 2

                  ArcSDE for Oracle11g 10
                  ArcSDE for Oracle11g 10 Service Pack 1


                  The diference is just the ArcSDE for Oracle11g 10 Service Pack 1 in the client machine, do I have to install it in the server machine and re-run the upgrade tool? Is the ArcGIS Desktop 10 Service Pack 1 in the client machine causing problems?
                  Is it necesary to have installed ArcSDE in the client machine to run the upgrade tool or just the ArcGIS Desktop 10 (Service Pack 2)?


                  Thanks