5 Replies Latest reply on Mar 7, 2012 10:18 AM by lscott-esristaff

    Problems with HotSpot tool

      Hi! I have used Hotspot analysis several times now, but am encountering problems for reasons I can't figure out.

      I am using a projected map of state zip code polygons joined with a table of data. Both the feature class and the table are in a geodatabase. I have tried using both a pre-made spatial weights matrix as well as a fixed distance, but get the following warning:

      Warning 000642: Problems reading -1721 of 0 total records

      Neither the feature class nor the joined table have null records.

      The script finishes, but returns an empty feature class.

      Would appreciate help figuring this out!

        • Re: Problems with HotSpot tool
          I have no clue if this would affect the specific tools & options within those tools you are using, but I'd personally probably try exporting the feature class with the joined attribute data to a new feature class so the geometry and attributes are all in one feature class without using any joins.  Just try running the same tool with the same options on that feature class instead to at least identify if it's an issue with the join for some reason.  Again, I've never tried it on a joined table, so don't know, but I know I have used other tables where joins either messed things up or the joined attributes were ignored in the output, so...
          • Re: Problems with HotSpot tool
            Thanks! I'll try that. For now, I was able to reproject my shapefiles and to re-join to the table and the tool worked. But creating a new feature class may be a more sustainable solution.

            Related question: the HotSpot tool now has the "Standardization" tab disabled, i.e. it is locked to a "None" default and I cannot change it. I very much need to use this feature to row standardize, but cannot. Any idea why? I have an Editor license.

            • Re: Problems with HotSpot tool
              Why don't you just first create a spatial weights matrix using that geoprocessing tool and enable row standardization there.  Then, use that SWM as an input in the hotspot tool.  Maybe not ideal, but, it should get the job done, unless of course row standardization doesn't work there either, in which case it may be a problem worth calling tech support about.  Again, just my 2 cents though.
              • Re: Problems with HotSpot tool
                Thanks! That's definitely an option, but an extra step... Row standardization is indeed enabled in the spatial weights matrix tool. But would be better for exploratory analysis to be able to forego matrix creation.
                • Re: Problems with HotSpot tool
                  Hi Arina,
                  What you will notice is that if you run the Hot Spot Analysis tool with row standardization or without row standardization, the results will be exactly the same.
                  That's why that option is disabled.  This ONLY applies to the Hot Spot Analysis tool.  For Anselin Local Moran's I, row standardization will impact the Index value, but not the Z score.  Row standardization has a definite impact on the other tools that include the Row Standardization parameter.

                  When I first wrote the script for Gi* I stupidly added the Row Standardization parameter (not realizing it has no impact on the results).  Unfortunately, once Esri releases a tool we cannot remove parameters (that's so we don't break existing workflows or models).  The only thing I could do was to gray out that parameter, which I did.  I'm very sorry for the confusion. 

                  Shoot :(  I just checked the documentation and it does not explain this.  I will correct this immediately.  Thank you for posting your question.

                  Again, my apologies,

                  Lauren M Scott, PhD
                  Geoprocessing, Spatial Statistics