8 Replies Latest reply on Mar 2, 2012 4:47 AM by kenmarshall

    Adding Addition GDB in SDE/SQL

    kenmarshall
      Hello Anyone,

      I can't add an addition GDB into SQLserver via SDE post install. I've tried a strong password in the second database and made a new empty folder for the database and still no luck. Keep getting native errors.

      My SDE password in not a strong password for my SDE administrator would that cause a problem?

      I've read other threads and tried those fixes but not luck. Is there other issues I havn't read about.

      Thanks
      Ken
        • Re: Adding Addition GDB in SDE/SQL
          eryanesri-ireland-ie-esridist
          Hello Anyone,

          I can't add an addition GDB into SQLserver via SDE post install. I've tried a strong password in the second database and made a new empty folder for the database and still no luck. Keep getting native errors.

          My SDE password in not a strong password for my SDE administrator would that cause a problem?

          I've read other threads and tried those fixes but not luck. Is there other issues I havn't read about.

          Thanks
          Ken


          Hi Ken,

          It's probably as you suggested; an issue with the sde password.

          But at what stage of the post install are you getting the error? Also, I'm not sure what you mean by making "a new empty folder for the database"?

          At "user information" it requests a username or password to connect to your sql server.
          Try using the sa or another sysadmin user at this stage.

          On the next stage, you need to enter your existing sde password at the "create spatial database stage".
          If this is not strong, you may need to change it.
          You can easily change the password in SQL Server but you will need to update any connection strings that use the SDE user.

          Dont forget, if you use application connect(an ArcSDE service), you will need to delete and recreate the service with the new password.
          This can e dine by running the post install, choose the custom setup and select create ArcSDE service option.

          Regards,
          Eoin.
          • Re: Adding Addition GDB in SDE/SQL
            kenmarshall
            Hi Eoin,

            I m new at this SDE/SQL stuff and learning as I go. I get my errors at the second window when I go to create Spatial database. When I say make a new folder I mean in the Create in folder option I created a new folder to see if that would fix it. It didn't.

            I think my problem is in the strong password that I didn't create when I did the install. Plus I can't log in under the 'sa' account cause I don't know the password either I didn't right it down during the install or something. Since I wrote this tread I been looking how to find my 'sa' password I found it in SQL but it is dotted out but what is strange my password for my 'sde' in SQl that is dotted out also doesn't match my password. So, I'm confused. Is there a default password they put in for you?

            So, I need to figure out my 'sa' password before I do anything. So I'm going to do what you suggested to see if it fixes it.

            Thanks
            Ken
            • Re: Adding Addition GDB in SDE/SQL
              eryanesri-ireland-ie-esridist
              Hi Eoin,

              I m new at this SDE/SQL stuff and learning as I go. I get my errors at the second window when I go to create Spatial database. When I say make a new folder I mean in the Create in folder option I created a new folder to see if that would fix it. It didn't.

              I think my problem is in the strong password that I didn't create when I did the install. Plus I can't log in under the 'sa' account cause I don't know the password either I didn't right it down during the install or something. Since I wrote this tread I been looking how to find my 'sa' password I found it in SQL but it is dotted out but what is strange my password for my 'sde' in SQl that is dotted out also doesn't match my password. So, I'm confused. Is there a default password they put in for you?

              So, I need to figure out my 'sa' password before I do anything. So I'm going to do what you suggested to see if it fixes it.

              Thanks
              Ken


              Hi Ken,

              The number of dots wont correspond to the number of characters in your password. It's just a standard way of hiding the password.
              If you're getting to the create database stage and able to log into SQL management studio you must be logging in as another sysadmin user.
              Your operating system user account?
              You could reset the sa user and sde user using that account.
              And create a new ArcSDE database using that account.
              • Re: Adding Addition GDB in SDE/SQL
                kenmarshall
                Yes I got through the create spatial database window and all the way through to the repository setup but this is not what I expected. I thought I was creating an addition GDB with a totally different name. But it just allowing me to update my existing GDB. I put a new name in the databse name/repository setup window and it unsuccessfully.

                So, can I make another SDE/GDB? I have it created up SDE scheme as all the write-up state to do. So far I have SDE/GDB up and running and being directly connected to it. I just can't get another SDE/GDB going. The instructions are very miniumial when it comes to creating an additional SDE/GDB.

                Any thoughts?

                Thanks
                Ken
                • Re: Adding Addition GDB in SDE/SQL
                  eryanesri-ireland-ie-esridist
                  Yes I got through the create spatial database window and all the way through to the repository setup but this is not what I expected. I thought I was creating an addition GDB with a totally different name. But it just allowing me to update my existing GDB. I put a new name in the databse name/repository setup window and it unsuccessfully.

                  So, can I make another SDE/GDB? I have it created up SDE scheme as all the write-up state to do. So far I have SDE/GDB up and running and being directly connected to it. I just can't get another SDE/GDB going. The instructions are very miniumial when it comes to creating an additional SDE/GDB.

                  Any thoughts?

                  Thanks
                  Ken


                  Hi Ken,

                  The process should be pretty much the same for any additional databases.
                  You need to specify a new name for the database in the "create spatial database" stage.
                  Does this complete successfully?
                  After this, the post install will setup the spatial repository within the newly created database.
                  Next stage is authorize. all these stages must complete successfully.

                  The last stage "create ArcSDE service" is optional and only used for application connect.
                  You dont need this if you're using direct connect.
                  If creating a service, remember to use a different port. i.e if you've used the default 5151 for your first database, use 5152 for the second.
                  • Re: Adding Addition GDB in SDE/SQL
                    kenmarshall
                    HI Eoin

                    I can't get past create spatial database window with a new database name keeps given me natuve errors.

                    Ken
                    • Re: Adding Addition GDB in SDE/SQL
                      eryanesri-ireland-ie-esridist
                      HI Eoin

                      I can't get past create spatial database window with a new database name keeps given me natuve errors.

                      Ken


                      Hi ken,
                      Okay some more questions.....
                      Are you using a SQL sysadmin user to connect at the "user information" stage of the post install?
                      Check this in SQL management Studio
                      Have you changed your SDE password to be a strong password?
                      Try checking the setup log:  SDEHOME\etc\sde_setup.log
                      • Re: Adding Addition GDB in SDE/SQL
                        kenmarshall
                        We got it the IT department forgot to put me as an administrator. We created the new database no problem working great.

                        Thanks so much
                        Ken