1 Reply Latest reply on Mar 19, 2012 1:34 PM by nscholtz

    ArcGIS 10.0 Export to CAD (DWG) Newbie - unable to get it to work

      I'm unable to export to DWG format some 3D models

      I go to the Toolbox --> Conversion Tools --> To CAD --> Export to CAD

      I select the only input feature class, which contains the 3D models.
      I leave the ouput type to the default DWG_R2010
      Output file to the default.
      I leave the Ignore Paths in Tables checked.
      And the Append to existing files unchecked
      And the seed file empty (seems to be for dgn, not dwg)

      I get an output DWG file the is 9K, where the geodatabase directory is about 32MB, and each separate model is close to 1MB

      I tried the forums and found in 9.x that you needed to to set the "CADType" field to '3D Polyine'

      Tried it still a 9K file size.

      Anyone understand what I'm missing

        • Re: ArcGIS 10.0 Export to CAD (DWG) Newbie - unable to get it to work

          I've been having this same problem as well since upgrading to ArcGIS 10 in September 2011. I'm at a large educational institution, and the export works pretty much everywhere on campus except for the lab where I regularly help architecture students export vectors to CAD. Different areas of campus do have computing IT administered in different ways. Previous to the ArcGIS 10 upgrade, I never had problems exporting to .dwg unless the input files were just too large for it to handle.

          I had a breakthrough today, though! It seems that the location of the input or output file has something to do with it. A shapefile in a folder on my desktop was input, output to a .dwg on the desktop, and I had exactly what you describe -- an empty, very small (8k) .dwg file. I moved that same folder to a networked fileserver, and exported it to the same dwg2010 default format, but also to the networked fileserver folder, and it worked perfectly. I'll post as I figure out more about this.

          In the past, I tried using the other, older .dwg filetypes, and that made no difference. .dxf has worked fine for us, but the files are typically much bigger in .dxf than they would be if the .dwg was working.

          This is the first time I've seen evidence that this is happening to others. I do plan on filing a bug report soon.

          Nicole Scholtz
          Spatial and Numeric Data Librarian