1 Reply Latest reply on Mar 20, 2012 7:53 AM by vsfoote

    "Out of Memory" while working with HEC-GeoRAS

    faizan72
      This solution is for ArcGIS 9.3
      Happens because 32 bit apps are not allowed to use more than 2 gb of RAM.

      Here the step by step solution:

      1. Install Microsoft Visual Studio 2008 (we need its command prompt to Unlock the 2 gb Limit form ArcMap)

      2. Go to start menu and run the command prompt from the Visual Studio Folder.

      3. Type, editbin /largeaddressaware "c:\program files (x86)\arcgis\bin\arcmap.exe"

      4. ArcMap should not be running.

      5. This should remove the error.

      for any problems email me at me_faizananwar   at   yahoo.com
        • Re: "Out of Memory" while working with HEC-GeoRAS
          vsfoote
          @Faizan72,

          On 32-bit Windows, even with LargeAddressAware (LAA) bit set, the maximum memory allocated by the OS is 2GB per user process unless the operating system is configured to use additional space.

          Believe the suggestion you should make would be to allow a 32-bit operating system to use additional memory (only if sufficient RAM is physically installed) by setting the /3GB flag in the boot.ini configuration file(Win XP Pro), or BCDEdit /set increaseuserva (Win  Vista or 7); but only if the system has more than 3GB of physical RAM. But some care should be taken as the shift into expanded memory ranges can cause stability issues when signed pointers are used.

          If you are on a 64-bit system, arcmap.exe and other components of the ArcGIS Desktop environment with LAA set will each be allocated a full 4GB of user memory space map.  Unfortunately, 32-bit Python 2.5 (or 2.6 and 2.7 of later ArcGIS versions) is not compiled LAA so geoprocessing can end up memory resource constrained.  Those and similar executables can benefit from toggling the LAA bit using EDITBIN from a Visual Studio load or a simple toggle utility as in this forum posting.

          Stuart