1 Reply Latest reply on Apr 9, 2012 8:44 AM by jwerts

    ArcGIS for Windows Mobile secure services issues

      I've been having some issues getting ArcGIS Mobile 10 (Windows Mobile) set up with secured (token-based) services.  I've gotten it to the point where I was able to download a project to device (Juno) and was prompted for credentials for the secure service, accepted and then downloaded the project successfully.  The first issue occurs when I try to post updates which fails every time.  Don't see anything in the log other than "MobileSync: Post Features Failure."

      Also, in Mobile Project Center, I am no longer able to save the project to the server (remote).  It brings up the login required dialog, which checks the login and just returns to the dialog again.  When checked in Fiddler, the following request is sent to the server:


      and "401 - Unauthorized: Access is denied due to invalid credentials." is returned.

      There's obviously a permissions issue going on here but after many hours, I can't seem to make any progress, and can't find any documentation for using ArcGIS Mobile 10 with secured services (can only find some 9.3 docs which I 'm not sure are current).

      The ArcGIS server is on a remote EC2 instance if that makes a difference.  I've tried running ArcGIS Mobile Project Center directly on the instance but it just freezes up (latest build 2550).

      So if anyone has any fresh ideas, I'd love to hear them.

        • Re: ArcGIS for Windows Mobile secure services issues
          These issues have been solved so I wanted to post up the solutions for anyone else that may need help.

          I had a couple different issues going on and this is what solved them:

          Saving projects from Mobile Project Center:

          From ESRI:

          IIS Settings:
          -Mobile folder has only Anonymous Authentication enabled.
          -Admin folder has only Basic Authentication enabled.
          -Content folder has only Anonymous Authentication enabled.
          -Grant the IUSR account full control to the Mobile folder.
          -Delete any existing projects from the Projects folder.
          -Before attempting to use Mobile Project Center after making these changes, close and reopen the application.

          After applying these settings, I was still getting directory access errors through the browser application.  After granting write/modify permissions to the machine's "Users" role to inetpub/wwwroot/ArcGIS/mobile folder, these issues were resolved and everything worked fine.

          Also, I was not aware of this thread until after I solved my issues, but would have been a good place to look:

          Downloading projects/Connecting to server from ArcGIS Mobile on Juno:

          At first the Juno would not connect to the server when "Secured Server" checkbox was checked.  If I left it unchecked, I could download a project with a secure service (after entering token credentials) and get data, but when the project opened,  I would get a "Error opening mobile cache" message.  It turns out our SSL certificate (Thawte) was not validating properly on the server (though it appeared to be fine in the web browser).  A check with this tool:


          and installation of intermediate certificate:


          solved the issues for the Juno.  After installed the intermediate certificate, the Juno is able to connect with "Secured Server" checked and download/open the project.

          Posting updates to server:

          Posting updates to the server was failing because I had the geodatabase version used in the mobile service set to protected instead of public, so the user in the service did not have edit permissions on the service.

          Hope that helps someone, not an easy task to get set up!