3 Replies Latest reply on Apr 30, 2012 5:52 AM by dobbinjp

    System.runtime.serialization and resolving reference assemblies with infowindow

    dobbinjp
      I am trying to get the infowindow example from the interactive SDK working. I am using Visual Studio 2010 SP1, ESRI Silverlight 2.4, .NET framework 3.5, and Silverlight version 4.0.

      Here is the sample I am implementing: http://help.arcgis.com/en/webapi/silverlight/samples/start.htm#InfoWindowSimple

      My code is copied from the example (with the necessary "MainPage" modifications to class name, etc. I cannot get it to run and I get some strange behavior....let me try to explain:

      The first time I run it I get an error message stating that it cannot load system.runtime.serialization. So, I add a reference to that and rebuild the solution (as per this discussion). Once I do that, I get another error: "cannot resolve the reference assemblies. Please check the reference assemblies. Object reference not set to an instance of an object." I remove and re-add the serialization instance, but I am in a vicious cycle between the two error messages.

      At one point I figured maybe it was because I had several Silverlight SDK versions installed (3,4,5) so I removed all but version 4. I still get the error.

      Does anyone have any ideas what is causing this? I am at a complete loss after hours of trying different things and googling the problem to death. Thanks in advance for any help you can provide.