0 Replies Latest reply on May 2, 2012 12:48 PM by mshadden

    missing values in attribute field (excel import)

    mshadden
      I have a variable, X, in an Arc file that I would like to copy as another variable, Z.  The data is from a replication dataset using a raster grid.  The original observations on X were a sample of grid squares, aprox. 300 out of 1,300 grid squares, taken from a survey.  The original authors interpolated the remaining 1,000 observations using IDW.  I am attempting to replicate their study, but using various methods of interpolation to show sensitivity in their findings.  The problem is that in their replication data for X they include the interpolated values in the vector/column/variable with the observed survey values of variable X.  I need to copy X and take out the interpolated values so that I may re-interpolate them using different methods.  I have attempted to do this in two ways.  First, I exported the data to excel, took the appropriate steps, then imported the data back into ArcGIS.  However, Arc now only recognizes it as a String because the missing values are entered as "<NULL>".  I have not found a way to correct this.  Second, I generate a new variable in ArcCatalog, Z, and Arc fills in all the observations with zeros.  Now, I cannot figure out how to copy and paste X into Z and then delete the interpolated values in Arc.  I have found some posts on message boars that suggest using the "Attributes dialog box", but none of my variables (attributes?) show up in the box.  Any suggestions?  Thank you.