3 Replies Latest reply on May 5, 2012 2:07 AM by RPictures

    Displaying layers from Model Builder

    RPictures
      Good day,
      Have some problem with displaying layers from Model Builder.
      Lets imagine: we have a blanc map document and starting a model from dialog box, that model somehow works with data, in result I want to add a list of layers in a map. Some of them are the result of geoprocessing and some - input layers. Also I want them to use some LYR files for displaying.
      But here is a trouble.
      I can't add into the table of contents any layer I want from my model only checking "Add to display". The results of geoprocessing are added automaticaly but are not displaying using LYR path set in their properties.
      What should I do to solve the problem?
        • Re: Displaying layers from Model Builder
          RPictures
          So there's no solution?..
          • Re: Displaying layers from Model Builder
            smehta-esristaff
            I can't add into the table of contents any layer I want from my model only checking "Add to display". The results of geoprocessing are added automaticaly but are not displaying using LYR path set in their properties.

            Not sure what you are saying.

            Try these:


            • You can add any input or output layer to display by checking the add to display option. If AFTER YOUR MODEL RUNS the layer does not get added to the display, in your model uncheck the add to display and check it again for it to refresh the display for the layer desired.


            • The final output AND any other output which is a Model Parameter will be added to display by default. So if you do want to force an output to be added to display in ArcMap, make it a Model Parameter.


            • Any feature class/ layer variable with a layer symbology set from its properties will honor the symbology if your model has run and the symbology applies to the new output. Read this help to understand the difference between checking and unchecking "All other Values" when you are creating a layer file to be used in variables.



            • Let me know if these options don't work for you.

            • Re: Displaying layers from Model Builder
              RPictures
              Maybe I should clarify...
              1. I tried to check and uncheck "Add to display" many times. But even Help says that it works only if I run model from model builder, NOT FROM A DIALOG BOX.
              2. I made all input data (feature classes) a model parameters, but they are not added into the table of contents after I fill the forms in dialog box and run a model.
              3. I did set the path to LYR in their properties but it still only the results of geoprocessing are added into the table of contents and NOT WITH LYR SYMBOLOGY.

              So I already did all you suggest and nothing works... That's why I'm asking for help or explanation :)