13 Replies Latest reply on Feb 12, 2015 11:22 PM by ncelik

    points to line

    adamsk10
      Okay, so I'm trying to use the points to line tool. I've used it before and it has worked fine. But for some reason now whenever I use the tool it will do its thing at the bottom of the screen and act like it's going to give me something. And it does, kind of. When the tool finishes running a new layer will pop up on the left side, i.e., January_1998_points_to_lines. And this is fine, and it will have whatever symbol it was randomly assigned under it. This is what happens when things go right, except for the fact that no lines pop up on the map when the layer does. It is just the layer, and after the layer pops up, if I try to click anything at all the program will not respond and I have to shut it down. This is really getting frustrating. I'm very new to this stuff so it could be a simple fix, but I have no idea. If anyone could help I would really appreciate it!
        • Re: points to line
          dlee-esristaff
          It sounds like you are using ArcGIS 10 with the background processing turned on (by default). Is it the case if you run Buffer tool?

          To turn the Background processing off, go to "Geoprocessing" on the top tool bar --> click "Geoprocessing Options ..." --> Under "Background Processing" menu block, uncheck "Enable" box. That will disable the background processing. Now if you run a tool from tool dialog, the processing window will stay until it finishes.

          Does Points To Line run through now? Are you getting the line output? If not, could you share your data and describe any parameters used (Line Field and Sort Field)?
          • Re: points to line
            adamsk10
            Unfortunately the same thing happened again. The buffer tool runs fine, but there is still the problem with the points to line tool.
            The data I'm working with started in excel, I added it to my map using the add XY data function. From there I exported the points to my geodatabase. This is where I'm supposed to be able to use the points to line tool. I only put in a value for the line field. The points I'm working with mark different locations where mid latitude cyclones have been recorded for a certain month of a certain year around the world. The lines I am trying to create would represent the tracks of these cyclones. Different cyclones would have different amounts of points, depending on how long they lasted. The line field value I select is 'storm' which should, and has in the past, connect these lines correctly. So, only points for storm 1 would connect, the same with storm 2 and 3 and so on.
            I have done the same thing with data almost identical to what I'm working with now. I'm not sure if the problem stems from the computer I'm working with or what.
            Thank you for trying to help me with this problem.
            • Re: points to line
              dlee-esristaff
              Could you post a sample data that can reproduce the problem?
              • Re: points to line
                adamsk10
                This is the excel workbook for April of 1994
                • Re: points to line
                  dlee-esristaff
                  Thanks for the data. What version of ArcGIS are you using?

                  I tested in ArcGIS 10 SP3. I could not use Add XY data to add the points directly because the new format .xlsx is not supported. So here is what I did:

                  1. Saved the Sheet1 from your file as a .csv file.
                  2. Used Add XY data to add the points to ArcMap - I specified the Geographic Coordinate System, GCS_WGS_ 1984.
                  3. Exported the layer to a feature class in a gdb.
                  4. Ran Points To Line based on storm values successfully. The output contains 243 lines. (I noticed some duplicated points in the input, e.g. two of the three points of storm value 1 are dups; the three points of storm value 4 are identical.)

                  Could this work for you?
                  • Re: points to line
                    adamsk10
                    I am using ArcGIS 10, I'm not sure what the difference between this and your version is.
                    I tried following what you did and it worked the first time, whenever I tried to replicate it though, it did not.
                    Whenever I try to save a .csv file I have three options, to save it as a CSV (Macintosh), CSV (MS-DOS), or CSV (Comma delimited).
                    I have tried all of these, even though I was pretty sure the Macintosh one wasn't going to work, I tried it anyway. I think I saved it as the second one the first time I tried it (the time that worked) but after that I get the same results I did before. It runs the points to line, the layer shows up on the left, but nothing shows up on the map and after that when I try to click anything ArcMap doesn't respond and I'm forced to close the program.
                    • Re: points to line
                      JQuinn-esristaff
                      I was just taking a look at the Excel sheet you provided; when I bring it into ArcMap and look at the field headings, they show values that don't match up with the headings in Excel:

                      [ATTACH=CONFIG]14237[/ATTACH]

                      I copied and pasted all of the cells into a new .xslx file, saved it, and when I brought that table into ArcMap, the field headings came in correctly:

                      [ATTACH=CONFIG]14238[/ATTACH]

                      The points to line and buffer tools worked successfully using point data created from this Excel sheet.  Do your field headings look correct when looking at the attribute table from the Excel sheet?
                      • Re: points to line
                        dlee-esristaff
                        Kailey,

                        I saved as CSV (Comma delimited) and I can repeat the process successfully.

                        When I tried to bring your Excel file into ArcMap, it displayed a message saying the data has no spatial reference; so the resulting point feature class is "No Geometry". So I am seeing differently from what Jonathan saw.

                        Again I am using 10.0 SP3. Perhaps some system differences are causing the problem?

                        When you followed my way, did you specify the GCS everytime? Was there any error message from Points To Line? Do you have any colleagues around who can try on their computers?
                        • Re: points to line
                          richardson.r1
                          I tried following what you did but could not, when I tried to run it, it did not run as you described. It runs the points to line, the layer shows up, but nothing shows on map and when I try to click ArcMap,  it did not respond. After that I close ArcMap. What version of ArcGIS are you using? There is a problem with the points to line tool, I suspect. I'm not sure if the problem is me or the computer. I'm very new to this program and unaware how to fix, I have no idea. What should I do to receive the information that you have received?
                          • Re: points to line
                            dlee-esristaff
                            Kailey,

                            I understand your frustration, but I would like to take a few more steps to track the problem.

                            1. Continue from where you are - you have an output from Points To Line, but not shown in map:
                                   Open a new map, not an existing one, and add that output to the map. Do yo see any lines?
                                   If not, right-click the layer and open the attribute table. Are there any records?

                                   Add the point data to the map. Right-click the point layer, select "Properties ...".
                                   Under the "Source" tab, do you see the GCS_WGS_ 1984  information?

                            2. To verify whether the Points To Line tool works on your computer:
                                   Please get the attached zip file - it contains a shapefile with 5 points and a field, ORIG_FID. Unzip the file to a folder.
                                   Open a new map, not an existing .mxd. Add myPoints.shp to the map.
                                   Run Points To Line tool, specify the ORIG_FID as the Line Field, and give an output name.
                                   Does the tool run successfully? Do you get two lines in the output? Does ArcMap freeze?
                                   Can you repeat the process again with a different output name?
                                   If this works, the tool works.

                            I have stated that I am using ArcGIS 10.0 SP3. Do you have any ArcGIS 10.0 SP on your computer? To check in ArcMap:
                                   Click "Help" on top of the window and then select "About ArcMAp ...". Do you see any ArcGIS 10.0 Service Pack number?

                            Thanks for your patience.
                            • Re: points to line
                              adamsk10
                              I added the points to line layers, the ones that wouldn't show up before, to a new map. The lines showed up this time. There are records and the information under the source tab does specify GCS_WGS_1984. There is a problem with the lines though, it is described below.

                              I downloaded the zip file you included and tried everything you said, and it all worked. So the tool must be working.
                              When I look under the "Help" and "About ArcMap..." It says that it is ESRI ArcMap 10.0 and farther right in parentheses it has (Build 2414).

                              I tried adding data again, out of curiosity, to see what would happen. Surprisingly, I got a different result. Each time I add data and use the points to line tool (I have done this several times tonight, but only tonight) the tool runs and gives me an output that appears on the screen without the program shutting down. But this output is not what I expected, I'll attach a screen shot so you can see, but there are several horizontal lines running across the map, which I know should not be there. The number of lines, and the placement, differ with each month and year I work with, but the same types of lines always appear. I'm not sure what is causing this, because it has not happened before (except when I added the lines which didn't work before to a new map document).

                              I have attached a screen shot of the output of my data and the excel file that goes with it.
                              • Re: points to line
                                dlee-esristaff
                                Kailey,

                                Thank you for taking the steps I suggested and confirming that the Points To Line tool works fine on your machine. The problem you had with ArcMap might be just "hiccups", depending on what had been done prior to the process in that map or even what other software or extension(s) were running or had been used at the time.

                                It seems you don't have any SP on your ArcGIS 10. Thanks for checking that.

                                Using your 2000 data, I reproduced the display as shown in your image. The GCS used in the display covers from 0 degree (left edge of the map) to 360 degrees (right edge of the map). So, when a line segment goes from longitude 350 degrees to 2 degrees, it is that long. For example the line of Storm value 76 is made up with 7 vertices; the longitude of the 4th vertex is 357.5 degrees and longitude of the 5th vertex is 2.5 degrees, so it is a long line; and technically it is drawn correctly in this "cartesian" like display coordinates.

                                I understand that in reality those two vertice are only a few degrees apart in longitude. So, one would expect that the line is drawn from 357.5 longitude to 360 and then restart from 0 degree longitude and end at 2.5 degrees (I am omitting the latitudes here). However the current system doesn't know that the line should wrap around the 360 or 0 degree meridian, so it just follows the coordinate values as in a Cartesian system.

                                Technically the Points To Line produces the line correctly, following the order of the point coordinates. You didn't see this problem before probably because the lines you had in the past didn't cross the 360 or 0 longitude or you used a projection in which this issue wouldn't occur. Can you tell which reason it might be from your side?

                                I am not sure what workaround is the best; some colleagues suggest that you first decide what GCS you will use to display your data and then edit the point coordinates so that a line wrapping around 360 or 0 degree longitude should have a vertex at 360 and restart with a vertex at 0 longitude. That way the line will be drawn following the given coordinates.

                                I have brought up this subject to our team - whether it is possible for our system to support the drawing with an option of going the "shorter" side of the globe. There may not be an easy answer very soon.
                                • Re: points to line
                                  ncelik

                                  Did anyone find solution to how to work this tool? No matter what I did, it just not working and giving error 9999999 or warning 001059.