10 Replies Latest reply on Mar 12, 2015 2:27 AM by mapwork

    Can't Install ArcGIS 10.1 tutorial data

      I'm doing a clean install of AcrGIS 10.1. I uninstalled the previous version along with its tutorial data. ArcGIS 10.1 installed and runs correctly. But when I try to install the tutorial data, I get a message that a prior version of the data is already installed and must be uninstalled first. No Tutorial Data entry appears in the Add/Remove Programs in Control Panel.

      I'd downloaded the ArcGIS_Desktop_Tutorial_Data_101_129030.iso file and burned the image to a dvd.
      I'm running Windows 7 64-bit and am installing as Administrator.

      Has any one encountered this problem?
        • Re: Can't Install ArcGIS 10.1 tutorial data
          Did you run the Uninstall utility from the root of the 10.1 installation DVD image, or manually run the uninstallers from Add/Remove programs?
          Since ArcGIS Tutorial for 10.0 was still present, there could be other components. Suggest you download and run the PatchFinder utility from the last service pack page http://resources.arcgis.com/content/patches-and-service-packs?fa=viewPatch&PID=66&MetaID=1843; should show any 10.0 components--not sure if it will pick up your 10.1, post back if it does.

          If you want to check the Registry first, the ArcGIS Tutorial Data installation lays down registry values at

          HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ESRI\ArcGIS Desktop 10 Tutorial Data.

          Review Esri KB 28709, you'll see the ArcGIS Tutorial Data has its own uninstaller, which you could run from a command window "Run as Administrator" manually. Enter:

          msiexec.exe /x {41B76534-B3C2-4FCF-B171-5291A3561051} /qb

          If running the Microsoft Installer package fails to uninstall, delete the whole key if still present. And then check for and manually delete the installation folder for the tutorial data, default is: C:\arcgis\ArcTutor

          Should clear things off to be able to install the 10.1 version of ArcGIS Tutorial.

          • Re: Can't Install ArcGIS 10.1 tutorial data
            Thanks for the information.
            I ran the patch and it turns out remnants of ArcGIS Tutorial Data v9.3 were still hanging around. That was a few versions ago & I suspect I uninstalled it using Windows Control Panel.
            I ran the command line uninstall as you suggested and it cleaned up the issue for me.
            • Re: Can't Install ArcGIS 10.1 tutorial data

              Glad you got it sorted. And actually you may have just had the 10.0 ArcGIS Tutorial Data on the system. 

              Both 9.3.x and 10.0 version of the ArcGIS Tutorial Data used the same GUID code {41B76534-B3C2-4FCF-B171-5291A3561051}, kind of an oops on Esri's part, so it would show as 9.3 version with the product code lookup of older PatchFinders, even though it was really the 10.0 installed.  No issue at 10.1 as the tutorial data again has a unique GUID of {D3DC1EEB-D2C8-4733-8E78-63A66C542C6F}.

              Also, will have to check on this because I would have expected the 101UninstallUtility.exe to completely remove the 10.0 (or 9.3) Tutorial Data--the utility does see the 10 tutorial data package for removal if installed.  But if it is not completing the removal, folks upgrading will have to manually remove the Tutorial Data as you have.

              • Re: Can't Install ArcGIS 10.1 tutorial data
                I was able to successfully install the 10.1 Tutorial Data after performing the uninstall as you described (I hadn't installed the new data yet when I replied before).
                From your description, it looks like this may be an issue with others who are upgrading and installing the tutorial data. I hope they find this thread to save themselves some grief.
                Again, thanks for the help.
                • Re: Can't Install ArcGIS 10.1 tutorial data
                  Just to clarify and avoid any future confusion: The GUIDs added to the list in KB 28709 for ArcGIS Desktop 10.1 appear correct and match what is in the setup.ini document in the 10.1 installation software.

                  The ArcGIS Tutorial Data for 9.3, 10, and 10.1 all use the same GUID. This seems to confuse the results displayed by PatchFinder.

                  ArcGIS 9.3 and 9.3.1
                  ArcGIS Tutorial Data {41B76534-B3C2-4FCF-B171-5291A3561051}
                  ArcGIS Desktop {5033400B-0977-45AB-94CE-CC135A8E1BBB}

                  ArcGIS 10
                  ArcGIS Tutorial Data 10  {41B76534-B3C2-4FCF-B171-5291A3561051}
                  ArcGIS Desktop {64665955-E1A1-4A8B-BFFA-673A95318909}

                  ArcGIS 10.1
                  ArcGIS Tutorial Data 10.1 {41B76534-B3C2-4FCF-B171-5291A3561051}
                  ArcGIS for Desktop {6C8365F4-1102-4064-B696-68842D20B933}
                  • Re: Can't Install ArcGIS 10.1 tutorial data
                    Yes, and here are the ArcGIS for Desktop 10.2 Product Codes. Note that now for the 10.2 release, the Tutorial Data finally has a version unique GUID.

                    ArcGIS 10.2
                    ArcGIS Tutorial Data 10.2 {F140AD42-459C-4016-8C41-2278FEF14935}
                    ArcGIS for Desktop 10.2 {44EF0455-5764-4158-90B3-CA483BCB1F75}

                    • Can't Install ArcGIS 10.2 tutorial data
                      Same problem here. I'm trying to install ArcGIS 10.2 tutorial data but can't since it says that 10.1 tutorial data is installed. I've checked everywhere but there's none. I also checked registry and there's no tutorial data. I also tried running the cmd line for uninstalling but says that the action is valid only for products that are currently installed.

                      I've never installed 10.1 tutorial data so I'm still confused as to where the previous installation is coming from. Hope somebody can help me
                      • Re: Can't Install ArcGIS 10.1 tutorial data

                        Me to. I cant install tutorial 10.2 data because 10.1 tutorial data is installed, but i dont remember installing 10.1 tutorial and i cant find it anywhere. Tried the patchfinder, but it can only find 10.2.2 stuff.


                        I hope someone can help.


                          • Re: Can't Install ArcGIS 10.1 tutorial data

                            Andreas Pedersen


                            Have a read of KB28709


                            From a command window (or a powershell window) you can simply issue the commands to force uninstall of the Tutorial data and any residual.


                            for 9.3, 9.3.1, 10.0, 10.1

                            msiexec.exe /x {41B76534-B3C2-4FCF-B171-5291A3561051} 


                            for 10.2

                            msiexec.exe /x {F140AD42-459C-4016-8C41-2278FEF14935}


                            for 10.2.1

                            msiexec.exe /x {19418AE4-521D-42E8-B775-C0B642BC92AE}


                            for 10.2.2

                            msiexec.exe /x {84FC829B-8795-4403-8623-B6814D8AEE4F}


                            or now for 10.3

                            msiexec.exe /x {265E6A02-2441-4305-B03F-A8F8812D739E}



                            But, only if you'd care to, before running the uninstall strings, you can open the Windows registry with -- regedit -- and review the packages to see which is installed by reviewing the uninstall keys.


                            On 32-bit system locate to



                            On 64-bit system locate to



                            You'd be looking for the uninstall string for the old version of "Desktop Tutorial Data"


                            As always, please be careful while in the registry--any changes, intentional or not, are immediate and permanent.


                            Let us know how you make out.