6 Replies Latest reply on Sep 28, 2012 6:54 AM by jdmcc

    Problem adding fields after a table join using a file geodatabase

    jdmcc
      I'm working through what I think is a simple workflow in ArcGIS 10.1 (specifically ArcMap) and I've come across what seems to me like a bug. I've tried this with 2 different datasets and a colleague tried it with a third dataset and we both got the same result.

      What's happening is that I'm joining a standalone table to a feature class (both stored in the same file GDB), adding a field to the feature class (via the attribute table window), and what I see is that the data from the last column in the joined standalone table is moved to the new field. I thought it might just be a visual thing, but if you run statistics on the new field it uses the values that were moved over.

      If you look at the standalone table on its own it is unchanged. If you close/reopen the mxd the problem goes away, and if you remove the table join everything goes back to the way it should be. The problem seems to be limited to file geodatabases in my testing. Doing the same steps with the same data as a shapefile and a dbf file doesn't cause the problem.

      The workaround is straightforward: don't add fields to a feature class if there's an active table join. While investigating this I even discovered that you can't use the Add Field tool on a feature class while there's an active table join.

      Has anyone else run into this with 10.1 yet? I'm pretty sure it's a bug, but thought I'd check with the community before filing a report.