0 Replies Latest reply on Oct 22, 2012 1:42 PM by pat.numainville

    Error response when running OD Cost Matrix solver through SOAP API

    pat.numainville
      Hi,

      I'm running the OD Matrix Solver using the SOAP API but I have run into an issue.

      The request is submitted and seems to be processed successfully by the server however the result is never returned. My client application received a Runtime Error from the ArcGIS Server(10.0) as soon as it finished processing.


      [TABLE="width: 95%"][TD="class: list-item"]INFO2[/TD]
      [TD="class: list-item"]String request succesfully processed. Response size is 4954286 characters.[/TD]
      [TD="class: list-item"][/TD]
      [TD="class: list-item"][/TD]
      [TD="class: list-item"][/TD]
      [TD="class: list-item"] [/TD]
      [TD="class: list-item"]INFO3[/TD]
      [TD="class: list-item"]NALayer [OD Cost Matrix]: Generated 475 x 475 x 2 OD Matrix.[/TD]
      [TD="class: list-item"][/TD]
      [TD="class: list-item"][/TD]
      [TD="class: list-item"][/TD]
      [TD="class: list-item"] [/TD]
      [TD="class: list-item"]INFO3[/TD]
      [TD="class: list-item"]NALayer [OD Cost Matrix]: Solve completed.[/TD]

      [/TABLE]

      [TABLE="width: 95%"][TD="class: list-item"]INFO3[/TD]
      [TD="class: list-item"]NALayer [OD Cost Matrix]: Loaded 475 Destinations.[/TD]
      [TD="class: list-item"][/TD]
      [TD="class: list-item"][/TD]
      [TD="class: list-item"][/TD]
      [TD="class: list-item"][/TD]
      [TD="class: list-item"]INFO3[/TD]
      [TD="class: list-item"]NALayer [OD Cost Matrix]: Loaded 475 Origins.[/TD]
      [TD="class: list-item"][/TD]
      [TD="class: list-item"][/TD]
      [TD="class: list-item"][/TD]
      [TD="class: list-item"] [/TD]
      [TD="class: list-item"]INFO3[/TD]
      [TD="class: list-item"]NALayer [OD Cost Matrix]: Copied network analysis context.[/TD]
      [TD="class: list-item"][/TD]
      [TD="class: list-item"][/TD]
      [TD="class: list-item"][/TD]
      [TD="class: list-item"] [/TD]
      [TD="class: list-item"]INFO2[/TD]
      [TD="class: list-item"]String request received. Request size is 412511 characters.[/TD]

      [/TABLE]


      HTTP Response:
      Server Error in '/ArcGIS/Services' Application.
      Stack Trace: [HttpException (0x80004005): Thread was being aborted.]

      I though the issue might be the request/response size (4954286 > 4096000 ) so I increased MaxRequestSize on the ArcGIS/services web.config and recycled the app pool but that didn't solve my issue.

      Smaller solver requests work fine.

      Any feedback would be appreciated

      Thanks

      Patrick