16 Replies Latest reply on May 11, 2012 11:54 PM by Hardolph

    Add X,Y data not working?

    samantham
      I am simply trying to make point shapefiles from x,y data. It doesn't seem to work, perhaps I am doing it incorrectly. Please check the image below it fully illustrates the issue I am having.
      [ATTACH=CONFIG]13683[/ATTACH]
      Thank you
        • Re: Add X,Y data not working?
          mzcoyle
          You mixed up your lat and longs.
          • Re: Add X,Y data not working?
            mimiller
            I am simply trying to make point shapefiles from x,y data. It doesn't seem to work, perhaps I am doing it incorrectly. Please check the image below it fully illustrates the issue I am having.
            [ATTACH=CONFIG]13683[/ATTACH]
            Thank you


            You sure you're using your x and y values correctly in the input??
            • Re: Add X,Y data not working?
              samantham
              You mixed up your lat and longs.


              I switched the values around, no result.

              [ATTACH=CONFIG]13686[/ATTACH]
              • Re: Add X,Y data not working?
                Dan_Patterson
                By chance are your longitudes missing a negative sign?
                • Re: Add X,Y data not working?
                  samantham
                  By chance are your longitudes missing a negative sign?


                  Pardon my ignorance, but I am not sure what you are trying to tell me. The coordinates in the original image 33.159106, -97.105016 when entered in google maps take you to the exact spot I am trying to import into ArcGIS. If the coordinates when entered into google maps display correctly, it shouldnt be missing any negative signs.
                  • Re: Add X,Y data not working?
                    m.gasior
                    The problem is that you selected Projected Coordinate System as a 'Coordinate System of Input Coordinates' and it should be Geographic Coordinate System (GCS).
                    Google uses WGS 1984 as a GCS so to use this GCS for your data you have to:
                    - in Spatial Reference Properties dialog box click Select
                    - then Geographic Coordinate System -> World -> WGS 1984.prj

                    BTW: coordinates assignment standard is:
                    X Field - Longitude: -97.105016
                    Y Field - Latitude: 33.159106
                    • Re: Add X,Y data not working?
                      samantham
                      The problem is that you selected Projected Coordinate System as a 'Coordinate System of Input Coordinates' and it should be Geographic Coordinate System (GCS).
                      Google uses WGS 1984 as a GCS so to use this GCS for your data you have to:
                      - in Spatial Reference Properties dialog box click Select
                      - then Geographic Coordinate System -> World -> WGS 1984.prj

                      BTW: coordinates assignment standard is:
                      X Field - Longitude: -97.105016
                      Y Field - Latitude: 33.159106


                      Revisiting this thread, attempted this solution today. However, before I can do a projection there are some problems I need to resolve I believe. When I go to file-> add data-> xy data and import my excel file it gives me an ArcMap Drawing Error. In addition, the attribute table for the XY data added is completely blank. Please see the image below to clearly illustrate the problem
                      [ATTACH=CONFIG]13940[/ATTACH]

                      I assume these are issues I need to resolve before I can fix the GCS projection issue.

                      In fact, I tried simply going to this XY point by using the Go to XY tool and inputing the long 32.680252 and lat -97.039914 followed by zoom to, and nothing happens
                      • Re: Add X,Y data not working?
                        dkwiens
                        ArcMap doesn't like spaces in the field names. While you're removing those, make sure there are no extra spaces at the beginning or end of your field names. It doesn't look there are any, but for future reference ArcMap also doesn't like funny characters in your field names (for example, '#').

                        Also, there is no such thing as latitude -97.039914.
                        • Re: Add X,Y data not working?
                          Dan_Patterson
                          check up further, that was longitude not latitude
                          • Re: Add X,Y data not working?
                            Hardolph
                            Samantha,

                            Please follow these Steps to avoid further confusion:

                            1.  go to your original spreadsheet and re-label the columns Field_Y_Latitude (the ones like 33.159106) and Field_X_Longitude (the -97.105016 ones).
                            2. resave the sheet as a .csv file called "XYPoints.csv"
                            3.  start ArcMAP and run the Add XY Data tool browsing to input "XYPoints.csv"
                            4. set X Field: = Field_X_Longitude and  Y Field: = Field_Y_Latitude.
                            5. at the bottom of the box hit EDIT... and Select in Geographic Coordinate Systems folder  North Americafolder:  "North American Datum 1983.prj "which will show up as  GCS_North_American_1983
                            6. In ArcMAP table of contents Right-Click on the "XYPoints.csv Events" layer and  Data > Export Data and specify the coordinate system as the layers source data in whatever file format you want Shapefile or Feature Class.

                            You can then either do step 6 again and use your Data Frames Projected coordinate system (assuming you have set it to that of a base map in Texas State Plane) for a projected shapefile output or use the Data Management > Projection and Transformations > Project tool and output your data into Texas State plane or whatever.

                            All the other posts have given correct advice, but don't bother trying to find a "solution"; you've just run into a common problem mixing up X and Y for Latitude and Longitude.  Maybe it just sounds better that way.

                            Hardolph
                            • Re: Add X,Y data not working?
                              samantham
                              Samantha,
                              5. at the bottom of the box hit EDIT... and Select in Geographic Coordinate Systems folder  North Americafolder:  "North American Datum 1983.prj "which will show up as  GCS_North_American_1983
                              Hardolph


                              Thanks a ton everything worked great! I just have a question at step 5, when I am going to edit and selecting North American Datum 1983. Is that defining the coordinate system of my xy input or is it projecting it?
                              • Re: Add X,Y data not working?
                                vaayu
                                That definitely seems like a "Define" since that is the first time you're creating the spatial data for a raw dataset.
                                Thanks a ton everything worked great! I just have a question at step 5, when I am going to edit and selecting North American Datum 1983. Is that defining the coordinate system of my xy input or is it projecting it?
                                • Re: Add X,Y data not working?
                                  samantham
                                  @Vaayu, thank you very much

                                  Importing the excel x,y data worked great. However, using the "go to x,y" tool from the toolbar up top does not seem to work. I input the coordinates exactly as they are in the excel file. I then try different options such as zoom to, flash, or add point and it does not work. What am I doing incorrectly?
                                  [ATTACH=CONFIG]14273[/ATTACH]

                                  Again this is a seperate issues from the input XY data from excel, that worked great. This is using the go to xy tool.

                                  Thanks again for your help everyone, I really appreciate it.
                                  • Re: Add X,Y data not working?
                                    Hardolph
                                    Samantha,

                                    for the Go To X-Y tool with the coordinates as shown you need to change the entry format to "decimal degrees" by clicking the small drop down arrow on the right end of the toolbar.  You have it selected for "degrees minute seconds" which would look more like 98 33 22 W for X and 35 48 27 N for Y in the entry windows.

                                    Hardolph
                                    • Re: Add X,Y data not working?
                                      samantham
                                      Samantha,
                                      for the Go To X-Y tool with the coordinates as shown you need to change the entry format to "decimal degrees"


                                      Thanks for your reply. I changed it to decimal degrees and input the coordinates, and it does not flash or zoom to the coordinates provided.

                                      [ATTACH=CONFIG]14275[/ATTACH]
                                      • Re: Add X,Y data not working?
                                        Hardolph
                                        Samantha,

                                        it does not go to the coordinates because you have reversed the inputs:   Long: = -97.080497  (the X coordinate) and Lat: = 33.155781 (the Y coordinate).
                                        The Go To tool does not "know" that you have reversed them, but there is no latitude -97.080497 or anything above -90 for that matter in degrees, so it just sits.

                                        [ATTACH=CONFIG]14279[/ATTACH]

                                        Hardolph